Gamemode not showing up in GMOD13!

Dear god I’m back again with another nooby question… :L

My gamemode won’t show up in Garry’s Mod, I do not know why…
I’ve checked my txt file, my gamemodes folder and everything seems to be in order.
I seriously do not know what’s causing the problem…

Can someone help??? :s

Which one are you using?

What do you mean?

Is it not loading up on your server or in the main menu of GMod?

On the main menu. :s

Ok make sure your gamemode root directory looks like this:
garrysmod/gamemodes/<insertgamemodename>

And you have a text file called:
<insertgamemodename>.txt

And your text file contains:



"Gamemode"
{
	"base"		"base"
	"title"		"My Gamemode"
	"maps"		"^gm_"//Gamemode map prefix
	"menusystem"	"1"
	"workshopid"	""
	"settings"
	{
	
	}
}


[editline]14th February 2013[/editline]

Text file goes inside of gamemode folder, the gamemode you created.

I entered all the in the txt file (which was inside my gamemode folder of my gamemode) and it still doesn’t show up on my gmod home screen >_>

I don’t know what to tell you man, any errors? Anything significant to the problem happening? Did you change something? I could link you to this video on how to set up a gamemode: http://www.youtube.com/watch?v=_d8rZnQtUJE

He means, what gamemode are you using -.-

Im sure i didn’t change anything…
The txt file and the gamemode name are exactly the same, i triple checked.
I don’t know either. So i guess ill check that video out. Thanks anyway.

Is there any way to do this without having to deal with setting up a dedicated server? I mean, my friend says he did it without it… i dont know whats wrong.

I use a test server for my mods, to make sure they work before I put them on my good server. I suggest it, running things multiplayer is way easier in my opinion.

I found out what wemt wrong. The txt file for some reason made itself gamemode.txt.txt…