Gamemode Not Working

The gamemode I am working on, called ‘Paratrooper’, will not work when I try to play it on GMod. It will show up on the gamemode list under options, but when I run it it shows the following in console:

KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file In
Gamemode,
Registering gamemode ‘fretta’ derived from ‘base’
Registering gamemode ‘Paratrooper’ derived from ‘fretta’
ScriptEnforce is disabled
Executing listen server config file
exec: couldn’t exec listenserver.cfg
InitFastCopy: only 51% fast props. Bug?

I don’t know which part of that is the error or how to fix because it is not showing me anything is wrong with my lua coding. Yes I am relatively new to coding lua and this may be a very simple fix, please post your answers or requests for the lua files if I need to put them on this thread.

Thank You.

THere arent any errors in your log, maybe post all the log?

Ok, this is the ENTIRE log that comes up in console:

Mounting hl2… OK
Mounting ep2… No permission
Mounting tf… No permission
Mounting cstrike… SteamMountDepot: Error SteamMountFilesystem 240 - (dependency 0 (217))
SteamMountFilesystem(4972,217,0x1267fd28=,0x1267fc18) failed with error 5: No Steam Content Servers are available
OK
Mounting dod… No permission
Mounting episodic… No permission
Mounting hl2mp… No permission
Mounting portal… OK
Mounting lostcoast… No permission
Mounting hl1… No permission
Mounting hl1mp… No permission
Mounting zeno_clash… No permission
KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file gamemodes/Jerry/info.txt
Gamemode,
Parent cvar in server.dll not allowed (sk_apc_missile_damage)
Parent cvar in server.dll not allowed (bot_mimic)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (r_VehicleViewDampen)
Garry’s Mod server.dll Build #086 [Jun 29 2010 20:16:17]
maxplayers set to 128
Unknown command “sv_allow_wait_command”
Steam config directory: c:\program files (x86)\steam\steamapps\sbamfan\garrysmod\platform\config
Parent cvar in server.dll not allowed (sv_scriptenforcer_initialkick)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (r_VehicleViewDampen)
Didn’t find particle function oscillating_movement
Didn’t find particle function random_number
Didn’t find particle function oscillating_movement
Didn’t find particle function oscillating_movement
Didn’t find particle function random_number
Didn’t find particle function oscillating_movement
Didn’t find particle function oscillating_movement
Garry’s Mod client.dll Build #086 [Jun 29 2010 20:16:14]
KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file In
Gamemode,
maxplayers set to 1
Unknown command “cl_thirdperson”
Can’t use cheat cvar cam_snapto in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_ideallag in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_idealdelta in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_idealyaw in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_idealpitch in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_idealdist in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_idealdistright in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_idealdistup in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar cam_collision in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_maxpitch in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_minpitch in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_maxyaw in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_minyaw in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_maxdistance in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_mindistance in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_orthowidth in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar c_orthoheight in multiplayer, unless the server has sv_cheats set to 1.
Unknown command “hud_showemptyweaponslots”
Unknown command “sv_backspeed”
GetAllManifestFiles: Unable to load maplist.txt
Can’t use cheat cvar fog_start in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_end in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_color in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_colorskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_color in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_colorskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_color in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_colorskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_startskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_endskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_color in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_colorskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_color in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_colorskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_color in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar fog_colorskybox in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar r_farz in multiplayer, unless the server has sv_cheats set to 1.
Can’t use cheat cvar r_farz in multiplayer, unless the server has sv_cheats set to 1.
maxplayers set to 1
Unknown command “sv_unlag_fixstuck”
Lua initialized (Lua 5.1)
======== Installing Table (De)Serialiser Module | ver: 1.3 ========
==== Advanced Duplicator v.1.72 shared module installed! ====
==== Advanced Duplicator v.1.836 server module installed! ====
KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file In
Gamemode,
Registering gamemode ‘fretta’ derived from ‘base’
Registering gamemode ‘Paratrooper’ derived from ‘fretta’
ScriptEnforce is disabled
Executing listen server config file
Couldn’t find scene ‘scenes/npc/female01/question21.vcd’
Couldn’t find scene ‘scenes/npc/female01/question31.vcd’
Couldn’t find scene ‘scenes/npc/female01/answer35.vcd’
Couldn’t find scene ‘scenes/npc/female01/gordead_ques03a.vcd’
Couldn’t find scene ‘scenes/npc/female01/gordead_ques03b.vcd’
Couldn’t find scene ‘scenes/npc/female01/nice.vcd’
Couldn’t find scene ‘scenes/npc/male01/nice01.vcd’
Couldn’t find scene ‘scenes/npc/male01/nice02.vcd’
Couldn’t find scene ‘scenes/npc/female01/oneforme.vcd’
Couldn’t find scene ‘scenes/npc/Barney/ba_run.vcd’
Couldn’t find scene ‘scenes/npc/Barney/ba_ohshit.vcd’
Couldn’t find scene ‘scenes/npc/Barney/ba_thisisbad.vcd’
Couldn’t find scene ‘scenes/npc/Barney/ba_headcrabs.vcd’
exec: couldn’t exec listenserver.cfg
InitFastCopy: only 51% fast props. Bug?
Lua initialized (Lua 5.1)
======== Installing Table (De)Serialiser Module | ver: 1.3 ========
==== Advanced Duplicator v.1.72 shared module installed! ====
==== Advanced Duplicator v.1.741 client module installed! ====
Registering gamemode ‘fretta’ derived from ‘base’
Registering gamemode ‘fretta’ derived from ‘base’
Registering gamemode ‘Paratrooper’ derived from ‘fretta’
— Missing Vgui material HUD/killicons/babycrab
Sending 10 ‘User Info’ ConVars to server (cl_spewuserinfoconvars to see)
Unknown Command: ‘team_menu’
Redownloading all lightmaps

I don’t see any errors in there, but why is it registering fretta 4 times? Or is that the console from two start ups of a single player game?

Did you add ’ “Changegamemode” “Fretta” ’ to your server.cfg? That’s what it looks like…