Gamemode will not start on Ded server

My game mode I gave coded will not start on a dedicated server

Any suggestions why?

I am using ulx map tod_me FY
To load the map
tod_me = map
FY = Gamemode

and it says that the gamemode doses not exist, Yes i have put it all in the right places any other reasons?

Also I can start a listen server with the game mode on just not use my real server.

Thanks in advance

Any console errors?

Nope

What happens when you start the server? You need to be more specific.

What gamemode?
What’s your console say as soon as the server starts?
What addons/scripts are you running besides the gamemode?
What map are you running?

All of those could effect the functionality of a gamemode.

[editline]03:28PM[/editline]

Oh, I see you edited your post.

[editline]03:29PM[/editline]

Ok, post exactly what your console says. If it’s a code problem, we need to know every detail possible.

There are no errors it just says when i try and change to the gamemode that the gamemode is non existent.

Copy and paste please.

Right after looking hard at the consule on the dedicated server i saw:



KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file gamemodes/FY/info.txt


^ is at startup

and when i try and change it to the gamemode:




ulx map tod_fightyard FY
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file In Gamemode,


[editline]09:02PM[/editline]

Here is my info.txt



"Gamemode"
{
	"name"		"FY
	"version"	"1.0"
	"author_name"	"Benjojo"
	"author_email"	"-hidden but it is a real address-"
	"author_url"	"http://www.garrysmod.com/"
}


[editline]10:15PM[/editline]

PROBLEM SOLVED!

"name"		"FY

I forgot to put an end quotation.

Thanks anyway.