Gamemode won't change to Garry's Mod Stranded

I have the gamemode Garry’s Mod Stranded in my gamemodes and the gamemode will not change from Sandbox. (SRCDS)
Here’s a look at my Command Line:

-console -game garrysmod +gamemode Garry’s Mod Stranded +map gms_TropicalIslands_v2 +maxplayers 50 -tickrate 33 +hostname DubServers Stranded +sv_gamemode “Garry’s Mod Stranded” -port 27015

And Cfg:

hostname “DubServers Stranded”
rcon_password “NOPE SORRY”
sv_lan 0
sv_kickerrornum 0
sv_loadingurl “”
sv_gamemode “Garry’s Mod Stranded”
sv_defaultgamemode “Garry’s Mod Stranded”
sbox_noclip 0
sbox_godmode 0
sbox_weapons 0
sbox_plpldamage 0
sbox_maxprops 50
sbox_maxragdolls 0
sbox_maxnpcs 0
sbox_maxballoons 0
sbox_maxeffects 0
sbox_maxdynamite 0
sbox_maxlamps 0
sbox_maxthrusters 0
sbox_maxwheels 4
sbox_maxhoverballs 4
sbox_maxvehicles 1
sbox_maxbuttons 10
sbox_maxemitters 0
sbox_maxspawners 0
sbox_maxturrets 0
net_maxfilesize 64
sv_downloadurl “”
sv_allowdownload “0”
sv_allowupload “0”

Please help!

change the command line from:


+sv_gamemode "Garry's Mod Stranded"

to


+sv_gamemode "gmstranded"

Hey Nate, I just tried it and it did not work, please help anyone! :slight_smile:

It’s supposed to be +gamemode.

Do you get a console output? Any errors?

You set the gamemode based on the folder name, not the actual name of the gamemode. In addition to that, the command to change the gamemode is “gamemode”, not “sv_defaultgamemode” or “sv_gamemode”.

So what do I need to change?

[editline]22nd May 2013[/editline]

I changed the cfg instead of sv_gamemode and default I changed it to just gamemode “Garry’s Mod Stranded”

[editline]22nd May 2013[/editline]

It says Couldn’t change active gamemode - Garry’s Mod Stranded not found

I just said it’s based on the folder name. Whatever the folder is named, make it that.

I did, and it did not work. :frowning:

EDIT: READ MY LATER POST, PROBLEM SOLVED

Rename the Stranded folder in gamemodes to


stranded

In your server.cfg, put this line somewhere in it


gamemode "stranded"

Then, obviously, restart the server.

I did this for another gamemode called Tiramisu 2. gamemode “Tiramisu 2” didn’t work for me for some reason, so I renamed the folder to “tiramisu” and set the line to gamemode “tiramisu”, and it worked.

Also, make sure the version of Stranded you have is actually meant for Garry’s Mod 13. So updated sometime after November 2012 preferably.

Also, make sure the gamemode is up to date. I haven’t heard of it.
We get a lot of littluns who download ancient gamemodes off of gmod.org.

I did what you said, and it is all updated. But it says cannot find gamemode ‘stranded’ still? It still isn’t working :stuck_out_tongue:

Are you using Linux or Windows to host your server?

Windows!

Just set up a SRCDS server and tried running stranded off of it. Yep, can’t switch gamemodes.

I got the gma off of workshop, extracted it, put it in, and it won’t switch.

How recent is it?

May 22, 2013. It’s still being actively worked on in the workshop.

Fixed. Name the folder gmstranded in your gamemodes folder just for the sake of this.

In the command line for your server, add the line:


+sv_defaultgamemode gmstranded

It switched over for me then.

To my knowledge sv_defaultgamemode was replaced by just “gamemode” in 13, so I’m not sure that’s actually what fixed your problem.

You shouldn’t put it in your server.cfg, it would be reloaded every time the map changes, you can just set it in autoexec.cfg and have it called once when the server is started.

I’m using a Fragnet. It only lets you use +sv_defaultgamemode. I left that blank while I was trying other methods. The second I filled that in and restarted the server, it worked.

Putting it in server.cfg does indeed work as our main community servers have been doing this for the last 5-6 months when we didn’t realize +sv_defaultgamemode (apparently?) came back.

Either way, Garry switching all this stuff around behind the scenes is starting to confuse a lot of people.

I think you need to create a txt file for the gamemode to work. This happened to me once and when I did this it worked.

Name it gmstranded.txt

and add



"Stranded"
{
	"base"		"base"
	"title"		"Stranded"
	"menusystem"	"1"

	"settings"
	{
		// TODO: put some settings here
	}
}


Place this file in the stranded gamemode
then try +sv_defaultgamemode gmstranded
and it should work.