[@ Garry] Enable secure websockets

I really love you for allowing websockets, but I can’t use them because my website runs on SSL. So, whenever I try to let it connect with the websocket, I’m getting this:

I’m not a fan of bumping, but I really need (want) this. Any chance Garry will reply? :smiley:

It seems to be complaining that your websocket isn’t secure, and it only wants to do secure websockets if the page is HTTPS. So it’s most likely an issue at your end.

[editline]1st March 2016[/editline]

The error literally says you have to use wss:// (WebSocket Secure)

Which doesn’t work, because it’s not implemented?

[editline]1st March 2016[/editline]

And after some Googling, I might be wrong about this. If I’m understanding http://stackoverflow.com/questions/9745249/html5-websocket-with-ssl correctly, WSS is always enabled? But when I try it with wss://, it doesn’t seem to connect :confused:

[editline]1st March 2016[/editline]

Sooo… anyone else having this same issue, or know what I’m doing wrong?

You’re gonna have to config your server to use wss, what server are ya running?

Using the default Windows server, but running on Ubuntu with Wine

erm, I’m talkin’ about the webserver

Oh lol, sorry… :smiley:
Server version: Apache/2.4.7 (Ubuntu)

Until rust server handles wss you might want to try mod_proxy_wstunnel to tunnel SSL websocket onto your local unsecure websocket.

Why are you still using wine btw?

Thanks for the link, did some research myself too and came across it but thought I needed something else :smiley:

As for using wine… my server is a 10-slot server for testing purpose only (debugging plugins, and websocket client) so wine will do just fine for now :slight_smile: If I’m going to host a ‘real’ server for others to play on, it will be the native Linux server.