Garry's Mod 10 Server Connection Issue!

Hello there.

I am currently experiencing issues when I attempt to connect to a particular server; the Aerolite Gaming Black Mesa Roleplay Server (IP 109.70.148.13:27018). I have Used this server many a’time in the past and have never had this issue.

The issue changes every time I connect.

The first time I connected the following error appeared: “Connection failed after 4 retries”. Then, the next time I connected it wouldn’t connect at all and classed the server as “not responding”, Then when I connected again, the materials it redownloads everytime for everybody would have taken weeks to download, when normally it takes under a minute.

As stated, I go on this server alot and have never experienced issues of the likes before, I am an admin on this server actually and the error just started today.

I have tried multiple methods to get this to work, but the error will not go away:

  1. Rebooted router via router page
  2. Rebooted router via power cable
  3. Tried to connect to other servers; they worked fine
  4. Restarted the computer
  5. Reinstalled Garry’s Mod completely

Whatever I do it just will not work, and it’s not a server issue because other people connect all the time, nobody else is experiencing problems and I know everyone on the server quite well.

If you have any ideas, please suggest below.

Thanks for reading!

Afterwars