Garry's Mod and every other Steam game will not begin to play as it did only several weeks ago (before the two updates since then.)

Several weeks ago: My first thread (when I only knew of GMod not working:)

It was only several days ago that Garry’s Mod (the latest version/update) was working normally. However, just recently I would click to start the game and it would show the normal “Preparing to launch Garry’s Mod…” window - only to be almost imminently proceeded by a flicker of what I noticed as the “Garry’s Mod” game window.

I’ve verified the integrity of the game cache, I’ve defragmented the cache files, I’ve reinstalled the game, I’ve deleted all the addons - all with no response whatsoever.

My specs for the Acer Aspire X5810:
Processor: Intel Core 2 Quad CPU Q8200 2.33GHz (4 CPUs)
Memory: 4094MB RAM
DirectX Version: DirectX 11
Driver: Driver Name: NVIDIA GeForce GT 120

Oh, and I have Vista.

About a week ago:

None of my other games will work. For example, when I start Counter-Strike: Source, the screen goes blank for several seconds and then puts my Steam window full-screen (remaining ‘minimized.’)

There have been two updates since then that haven’t made an effect at all.

Please help. Cheers.

I’ve got a similar issue. Someone please answer.

Try to reinstall either Steam, the games, clean your registry, install Windows 7 or uninstall Vista

I’ve tried reinstalling Steam and the games.
I’ve heard that it’s dangerous to fiddle with the registry and I really don’t think it’s to do with this.

Oh, and I’m not shedding out £80 or so for another OS.

I have a similar problem, when I start Garry’s Mod or CSS it just says Preparing to launch…and doesn’t do anything.

Looks like it never will be solved.
Two updates have been and gone without any effect.

Anybody reckon there’s a particular “launch option” that must be inputted?

[editline]6th September 2011[/editline]

One of the Football Manager FAQs said that renaming the “ClientRegistry.blob” file to “ClientRegistryOld.blob” (enabling Steam to make a new file) would help. Alas, it did not.

I have been having this same problem for months. I tried reinstalling Steam, all of my games, updating all my drivers, cleaning my registry, deleting ClientRegistryOld.blob, and of course verified game integrity.

None of my source games worked, but when I deleted the Steam folder completely from Program Files (x86) and then completely reinstalled everything, all the sudden my Orange Box games started working.

But still I cannot play CS:S or Garry’s Mod… they just say preparing to launch… and then hl2.exe *32 runs in the background.

I’ve contacted Steam Support 3 different times and I HAVE YET TO GET A SINGLE RESPONSE. I’m beginning to think that they will never solve this problem.

I’m running Windows 7 Ult 64 bit btw, and my specs are 2x as good as OP’s

Aren’t there any crash logs or similar?

No I don’t think so, because it’s technically not a crash, it just doesn’t start.

[editline]6th September 2011[/editline]

Okay, I just deleted “ClientRegistryOld.blob” and now whenever I start any Steam game it says, “This game is currently unavailable. Please try again at another time.”

[editline]6th September 2011[/editline]

False alarm. Verified cache and defragmented files lead to the original problem…

-snip-

Just out of interest how long are you leaving it on the “Preparing to launch Garry’s Mod…” screen?

One of the updates made we wait 20min on that screen before the game finally launched.

The “Preparing to launch…” screen is displayed for mere seconds before the screen goes blank and goes back to the Steam window.

P.S. If your game actually works, I’d recommend verifying the game cache and defragmenting the game files - it should solve that 20 minute problem.

-snip-

Bump.

Is there absolutely no solution?

I may be able to solve your problem. I had this exact issue a year ago, and I tried everything - even formatting my hard drive. My last resort was to make a new Steam account and buy a game to see if it would work. Thankfully, it did. I would advise anyone with this problem to make a new Steam account and buy the cheapest game you have that doesn’t work. If this solves it, then unfortunately the only way to play the Steam games you love is to buy all the ones you need over again on the new account. Either that or contact Steam support, but when I asked, they couldn’t do a thing.

Good luck, and I hope I saved you some of the trouble I spent a year going through.

I really hoped it wouldn’t come to that!

However, from seeing other applications (as well as Steam games) not working, I think my computer may have a problem in itself rather than just Steam. Oh well…

Are you running the latest drivers/direct x ?

Okay Uni Gent.

It sounds like one of two things is happening.

  1. Your PC isn’t liking any of the games.

OR

  1. Steam is being Steam.

I’ll go contact a friend of mine from Valve and ill see what I can do.

(Btw, its Acid who im calling)

I have a strong feeling that it is something wrong with my PC.

I have reinstalled Steam and reinstalled the games, however they still do not work sufficiently.

Thank you for your reply, I hope this Acid fellow can help!