Garry's Mod clearing/disabling/fucking up my desktop

Every time after I exit or Alt Tab out of Gmod, my desktop has no icons, I cannot right click it, there is no bar at the bottom, and I have to restart my computer.

Anyone know what the hell is going on?

its ONLY with Gmod

Try re-installing, that or maybe garrysmod is’nt compatible for youre lap top, it was’nt with mine

:unsmith:

I’m not on a laptop >_>

I’ll try reinstalling in a bit but idk

To fix that, click CTRL ALT DEL, go to the “Processes” tab, and click “End Process” on “Explorer.exe”. Then go back to the main tab (“Applications”) and click “New Task…”. Type “explorer.exe” and click Enter.
Edit:
In other words, you need to restart explorer.exe.

Edit 2:
An alternative way to solve this is to run the game in windowed mode. Don’t like the border or that the game is smaller than your screen? Change the resolution to the same as your desktop resolution, then right click Gmod, click Properties, Set Launch Options and type “-noborder” to disable the border.
This makes your Gmod look exactly like fullscreen, except you can ALT TAB without the game minimizing.

Oh fuck :xd:

Sorry i read desktop as laptop :xd:

This seems to have fixed it ^^ im in Gmod and alt-tabbed right now and all my icons and my bar are there so ty! :smiley: