Garry's Mod Completely Freezing when trying to join server

Whenever I go to join any server, my entire Garry’s Mod will freeze up at 6 bars in “retrieving server info”. Then, after 10 minutes unfreezes and jumps ahead in the bar by like, 10 bars. Then after another 10 minutes it says it’s trying to install the map I already have for the server then times out.

I’ve done the following:
-Verified Gmod, CSS, HL2, TF2, and all other games dealing with Gmod
-Reinstalled Gmod
-removed any and ALL addons
-Deleted all of my Gmod folders and reinstalled them
-Downloaded everything I would need for the servers I tried to connect to
-Made sure Firewall was okay with Gmod
-reinstalled STEAM(Yes, all game installed all over again)

It’s VERY obnoxious that I have to do all of these just to be shown that nothing is working. I dont have any Viruses or anything that would cause this issue. And before it’s said that “Maybe it’s your computer” It worked PERFECTLY fine literally a month ago. Nothing has changed besides the Garry’s Mod update I installed.

Any and ALL help is VERY appreciated since I’ve been very agitated over this not working for whatever stupid reason it is.

o to options, go to multiplayer then put “Do Not Download Custom.”