GARRYS MOD CONSOLE CRASH (need a fix)

Hello everyone i have a problem i was talking to my friend and he said i have to type something in the Console (This thing ~ then it opens that window?) weeeellllll whenever i try to open it my gmod Completely crash’s and I go back to the desktop and it says “HL2 Has Stopped Working” (Im on windows 7 btw) this piss’s me off! Is it just me? Its Been going on for like a year now…PLZ HELP D:

System Specs, Addons Installed, Did it ever work?

umm…What?

[editline]20th July 2011[/editline]

o umm no it has never worked…how do i find my System Specs?

Go to start and then search “dxdiag”. Run it and give us all the important shit.

Processor: Intel® Pentium® Dual CPU E2140 @1.60GHz 1.60GHz

Installed Memory (RAM): 4.00 GB (3.24 GB Usable)

System Type: 32-bit Operating System

Pen and Touch: No Pen Or Touch Input is available for this Display

[editline]20th July 2011[/editline]

Time of this report: 7/20/2011, 18:06:52

   Machine name: CHASE-PC

Operating System: Windows 7 Enterprise 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110408-1631)
Language: English (Regional Setting: English)

System Manufacturer: LENOVO

   System Model: 2222222

           BIOS: Lenovo BIOS Version: 52KT37A.ROM V3.7A

      Processor: Intel(R) Pentium(R) Dual  CPU  E2140  @ 1.60GHz (2 CPUs), ~1.6GHz

         Memory: 4096MB RAM

Available OS Memory: 3318MB RAM

      Page File: 1436MB used, 5198MB available

    Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: 96 DPI (100 percent)

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

 DxDiag Version: 6.01.7601.17514 32bit Unicode

[editline]20th July 2011[/editline]

Im vary new to this so im VARY sorry if i am pissing anyone off…

I need help BUMP

well why do you need to open the console in the first place?

I’ve had this problem with my old PC. After a long session of playing GMod, I tried to open the console but the game instantly crashed. However, my old PC could only handle GMod on the lowest settings. So I started to assume that my PC was just too shitty to open the console (yes, I know it’s noobish…)…

i need to open it cuz i was made Admin on a server and you need console to use all the Admin settings