Garry's Mod Crashes after launch.

It worked about 3 months ago, but now it just doesn’t work after It just closes without any error messages it just gets to the blue loading screen and it crashes. I have tried everything i have found to fix it but nothing worked. I have re-installed Gmod, deleted all the addons, verified game cache etc. but nothing worked! Please help i love this game!

My Specs:
CPU: AMD Athlon II x3 425 (2,7Ghz)
GK: Palit GT640 1GB DDR3
RAM: 4Gb DDR3 1066Mhz
HDD: 80Gb+300Gb
OS: Windows 7 Professional

remove all of your addons from your game folder and unsubscribe to them all, then start adding them back in one by one till it crashes

essentially unsubbing and removing them entirely should get the game to launch

I have unsubbed every addon and there are no addons in my folder but it still just crashes like previously.

Delete your entire directory uninstall it/re-install it.

I did that too but it still crashes.

Can I see your start script?

(Just a shot in the dark but) Try updating your graphics card drivers.

Try verifying your game cache to see if that does anything. Another thing that may help (Not big of a chance) is switching to Steam BETA if you have not already done it. Fixed some problems for me but idk if it would work in this type of problem you are having.

My friend had the same problem.

Try verifying the integrity of TF2. something to do with mvm? idk, it helped him.

If that doesnt help, steam > garrysmod (right click) > properties > set launch options> put in -debug

Ans report them back here.