Garry's Mod crashes on startup

When I start Garry’s mod, the usual happens, the ‘Preparing to launch Garry’s Mod…’ box pops up and when it closes and when Garry’s Mod would normally start, an error simply pops up. Nothing happens besides that, the screen doesn’t turn black or anything, just this little guy appears on my screen:

http://www.cubeupload.com/files/750600error.png

This same error has been happening for all my other source games that I’ve recently tried to play.

I’m running Garry’s Mod on Windows XP and I’m absolutely sure that I have plenty of memory, as I have played it without a hitch before.

Don’t even bother asking these because I already tried them:
> -dxlevel 9
> -dxlevel 81
> -dxlevel 80
> Update Drivers
> Reinstall

Did GMod create mdmp files?

Verify the integrity of the game cache, sometimes works, it’s in the local files tab of Garry’s Mod properties, if not, I really don’t know sorry man.

Yeah, I already verified the integrity of the game cache

How do I tell if it created mdmp files?

Should create them in the steamapps directory, I THINK.

If it does, they’re not there.

have u reinstalled steam? sorry for slang eating grapes

In the time it took you to explain the bad grammar you could of just fixed it.

Yeah, well you see I was eating and had to get out and my typing is faster than me going back

do a search of the whole steam directory, subfolders and all, for files with MDMP in their name.

  1. Reinstalled Steam, still doesn’t work.

  2. There’s only MDMP file, ‘steam_1267_assert_2010_6_9T17_24_14C0.mdmp’

Erm a wild stab in the dark (sorry for not being much help) tried deleting the clientregistry.blob in the steam folder, then start up steam?

Can you send me your mdmp? I think I know what might be causing the crash, could you try restarting Steam?

I have 21 now, but I can’t find the other one…