Garry's Mod crashes right at the startup

Launch Gmod, opens up in full screen, see it loading… crash to desktop without any errors displayed.
This has only happened today, which is really odd, since yesterday my game was running fine.
I have three DMP files I can show.
http://dumps.metastruct.uk.to/dumper.py?dump=hl2_164_crash_2013_5_19T20_39_30C0.mdmp
http://dumps.metastruct.uk.to/dumper.py?dump=hl2_164_crash_2013_5_19T20_27_32C0.mdmp
http://dumps.metastruct.uk.to/dumper.py?dump=hl2_164_crash_2013_5_19T20_26_52C0.mdmp

I believe that two of those dumps were recorded before I enabled steampipe beta on most of my games.
One other one was recorded after enabling steampipe. (The first linked file; ending in 30C0.mdmp I think.)

I have tried restarting steam and I have also tried defragging/verifying Garry’s Mod.

Put your dumps into here then send the links.

Thanks, I edited the OP.

It’s crashing upon initializing Awesomium, I’m surprised that validating did not work. You may have to reinstall.
[editline]19th May 2013[/editline]

If there’s anything you want to keep, rename your GMod folder garrysmod_old, then reinstall from there.

Strange… even reinstalling didn’t work.

Actually, it seems that none of my games seem to want to launch.
And Skype likes to crash upon answering a call, too.

I suppose I’ll have to look at more than just Garry’s Mod now.
I’ll go ahead and mark this as solved, since it doesn’t really apply to just Garry’s Mod anymore.