Garry's mod crashes right before map finishes loading

So Garry’s mod was working just fine today, when all of sudden it didn’t finish loading any maps at all. It crashes the very instant it finishes loading a map. Any map. I tried restarting my computer, but that didn’t do anything. It started happening all of sudden, and I don’t know what is causing it.

Did you update all your maps to the lastest version of garry’s mod? cause they just released a update today :c

Map change has only every crashed when I find the map files were corrupt, it’s happened a few times over the years, for some mysterious reason. Is it happening for “every” map it tries loading?

That. and you might need to uninstall all the maps you have for it and reinstall it. that should at least allow garry’s mod to redownload anything thats missing. Thats if you also delete your addon folder

The maps are all fine, the game simply crashes, no errors at all! The game still crashes without an error or anything!

same problem here. been happening for a couple days now…

  1. Are you loading maps for SP or MP?

  2. Try using the default_sandbox maps. (gm_construct or gm_flatgrass)

  1. I’m loading maps for SP
  2. Will this work?

[editline]11th July 2014[/editline]

So, gm_construct and gm_flatgrass don’t work either.

Try putting -dxlvl90 in your launch options. Try the default maps again.

I don’t think it has to do with DX level, it always worked fine. Plus, I think it’s set as DX 9.0 automatically on my Gmod.

Do you have any legacy addons?

It didn’t work.

[editline]11th July 2014[/editline]

What do you mean by Legacy addons?

SVN’s, Inputted files into your addons folder.

The only SVNs I have are TDMCars and in general, cars. They never caused any trouble for my game. But what do you mean by inputted files in my addon folder?

Guys I really need help please, I can’t play Garry’s mod because of this.

Are your video drivers up to date?

They are. All of this just started happening all of sudden. Everything was working, and I made no changes to the game when it started happening

The same exact thing is currently happening to me.