Garry's Mod crashes when ` is pressed

I have been getting many crashes lately. (Dunno why, usually when loading up a game)

I was playing TTT and my buy menu was (still isn’t) working. I pressed ` to open my console and Garry’s Mod crashes.
Coincidence? Maybe.

I try this again, same server and all, and it crashes when I pressed `.

So I decide to wipe my whole Garry’s Mod folder and start a fresh one.
Everything is going great. Buy menu is still not working in TTT and I press ` …

Crash.

I ragequit and deleted local files and made a brand new folder again. Still crashes.
Any suggestions? I had this for weeks and I had to break out.

Do you have an odd keyboard layout?

…try a different server?

Normal querty keyboard.

I have played single player, and even in the main menu it has crashed.

qwerty keyboard, how can you miss it if those buttons are in a row?

Unbind the button? unbind ` to console

Bind ` “crash”

lol

Yea! To do that he needs to acces the console. What happens if you start garrysmod with -console ?

don’t press `

I know where my ` is…

I did start it with -console, same result. The “Enable Developer Console” box is checked, too.

It’s hard playing Garry’s Mod without the console. It’s like eating cereal without milk.

Agreed. I’m getting the same thing too. Guess what my console button is… `. Maybe it’s a cursed key or something.

He’s referring to the word QWERTY

I realized this after a day that was posted.

I’m getting many other funky errors now, too. My Garry’s Mod folder has nothing installed yet. Mostly “Reference Memory” errors. The day all this started happening, I started seeing black textures in DoD, CS:S, and HL2: DM.

i would ask on the steam support

i will also investigate this