Garry's Mod crashing after October 2016 update

Recently, a new October 2016 update was pushed for Garry’s Mod.
Excited to try it out, I load up a map on Gmod (gm_corleone_night, a map I made), and the game crashes on me. I try again, this time on gm_flatgrass and it still crashes, littarly unplayable! Help!
EDIT: Even if I try to change my graphic settings the game crashes, Garry, plz fix

Hello everyone! I am happy to announce that my Garry’s Mod now works!
For anyone still struggling, this is what you need to do:

  1. Make sure you make backups of your important Garry’s Mod files (ex. Addons, Maps, Saves, Dupes ect.)
  2. Delete Local Content on Steam by right-clicking Garry’s Mod, then clicking “Delete Local Content”
  3. After that, then proceed to C:/Program Files (x86)/Steam/steamapps/common/GarrysMod and then delete EVERYTHING, including the file named GarrysMod.
  4. When thats done, then simply reinstall Gmod.
  5. Done!

Have you tried removing/disabling all of your addons? I can’t reproduce on a vanilla game.

Yeah, I have tried disabling my addons, but it doesn’t seem to work.
(BTW I have already tried the verify integerity of game cache, it didn’t work either.)

Try putting -dxlevel 95 in your startup parameters.

Im getting about 10-20 reports of players games crashing when loading into both my servers after the update!

Gamemode? Does it happen without addons?

It’s on darkrp, but i really can’t test it much because i can’t go about rebooting the server loads, trying to setup a dupe server to test it with but the fact it only happens to some people some of the time makes it kinda difficult to even test :frowning:

( And its definitely caused by some change in the update, it never happened once before the update )

Nope, still crashing. After 1400+ hours of Garry’s Mod, now the game has finally given up on me?
I’m sad now :frowning:

A hotfix update for a memory leak should be coming out tomorrow

Oh okay, I hope that should fix all of my problems…
Thanks for your help!

Nice, now my server has crashed 8 times in 2 days, for absolutely no reason, sick update love it

I know right! I can’t even play Gmod anymore! I’ve tried deleting all my addons, uninstalling gmod, verifying game cache, and even mat_dxlevel 81 but nothing has worked!