Garry's Mod crashing when playing mp3 extension files in the game

Before I go on any further:

  • I did verify cache multiple times, I even deleted some content and then verified cache. No use.
  • .mp3 files work perfectly on desktop. Other games too.
  • The issue links to vaudio_miles.dll (which doesn’t exist in the garrysmod binary), which is a file found in SDK Base (2007/2013). Perhaps Gmod links to those files for some reason?

In order to find this an active issue, I used console commands to play mp3 files. When I did that, the game crashed.

The only way the game worked was when I set launch options to -nosound (which obviously disables any sounds).

Help will be appreciated.

-Darkness

I’m assuming you have this issue on Windows. Do you have any crash dumps? Which sounds specifically are causing you to crash?

You can find crashdumps in your SteamApps/GarrysMod directory and they’ll end with “.mdmp”.

Any mp3 extension files. Doesn’t matter what file that is.
I tried this for instance (console): play music/hl2_song3.mp3 - the result was a crash. Same with other mp3 files.
I opened some mp3 files in different audio softwares, like Windows Media Player, Audacity, VLC and others. I had no issues at all.

I can send a crash dump, but I’m afraid you’ll get this, what I mentioned earlier (I found this issue by checking a .mdmp file, I can send one if you would like to investigate further):

P.S: This only happens with Gmod, other source games (and mods) display no such problems.

I’ll be able to see much more than just the name of a binary from the crash dump, don’t sweat it. I’ll PM you a link you can use to upload any files.

Update:

I just read the dump file
“Unhandled exception at 0x2CF01728 (vaudio_miles.dll) in hl2_161029_crash_2016_11_1T21_57_20C0.mdmp: 0xC0000005: Access violation reading location 0x00000001.”

(note, my Steam is located on disk F:\ and the issue comes from a completely different disk)

Original Location: D:\Source SDK Content files\Ultimate SSDK v3\Source Engine 2007\bin\vaudio_miles.dll

Question is, why does Garry’s Mod crash because of a file located on a completely separate disk? What’s going on?

Do you have “D:\Source SDK Content files\Ultimate SSDK v3\Source Engine 2007\bin” in your system PATH variable by any chance? Note: it might’ve been automatically put there by some bullshit even if you didn’t do it yourself.