Garry's Mod Dedicated Server Issue

I’ve had this problem for awhile now; it hasn’t changed with the update. Whenever I use -console to start the server, I cannot join the server any way and it doesn’t show up in the server browser. When I type status in the console of the server, it thinks for a second and displays nothing. But when I remove -console from the batch, it starts up with the source server interface and works perfectly fine. What is going on here?

What else do you have in your command line start up? Also is the server populated when you run status?

^That’s what my startup options are.

No, the server didn’t have any people when I run status, but no one including myself can join and the status command works fine with no people in the server in the source ds interface console.

Are you running multiple servers on the same machine if so can you specify a port? use +port

I’m thinking it’s running out of ports thus sitting there and not knowing wtf to do.

Nope, I’m not running multiple servers, and at the bottom of the console window it shows the port as 27015 which is the standard.

https://dl.pushbulletusercontent.com/P00rmCnG4Bz099bDQWyoyRvVHbIgKA6n/Capture.PNG

Here’s your issue. It’s not grabbing an external ip.

I don’t think it matters, because this is what srcds interface looks like that works:

https://dl.pushbulletusercontent.com/qKFv4OvsQFybR1Go15Aki0zPkVqmCNdn/Capture.PNG

Just start your server with

+ip xxx.xxx.xxx.xxx (Your external IP, portforwarding enabled)

If the server is locally hosted, try +ip 127.0.0.1 and try to connect

(Command: connect 127.0.0.1:27015)

With that, the console says WARNING: NNET_OpenSocket: bind: WSAEADDRNOTAVAIL and it pops up Engine Error: Couldn’t allocate any server IP port.

The computer with the server on it is a Windows server that I am accessing through Windows RDP, so I can’t run gmod on it.

[editline]2nd June 2015[/editline]

It does the same thing without -console, and my ports are forwarded correctly and my friends are able to join the server when it is in the interface mode.

is it hosted on your network/a home network or like a proper server? if it’s on a home network you shouldn’t need to give it an external ip

Here’s the startup log of the console with -console and without the +ip:

[editline]2nd June 2015[/editline]

Yes, it is on my home network and it has a static IP of 192.168.1.111 and the port 27015 is forwarded to that IP,

[editline]2nd June 2015[/editline]

OK, so I just tried it with my TF2 ds and it’s doing the same thing. When ever I start it from the interface, the server shows up in the browser and is join able, but whenever it has -console, it is unjoinable and doesn’t appear in the server browser.

Anyone have a solution to this problem? It’s still bugging me.

Put -console as the first argument after srcds.exe
(something like:)


srcds.exe -console -game garrysmod +sv_lan 0 +gamemode terrortown +host_workshop_collection 1234 -authkey 1234

If not, have you tried validating the server?

Change ‘srcds.exe’ to ‘start srcds.exe’. Also add ‘+maxplayers <specified number>’

You just need ‘srcds.exe’

It’s because you didn’t specify a map… lol.

add “+map ttt_waterworld” to the end