Garry's Mod disconnects me from every server soon after I join

I have been having this problem since shortly before the switch to SteamPipe and I decided I’ve waited long enough. Every time I connect to a server of any kind, it will say I’ve lost connection after 5-30 seconds and it just forces me to leave after the timer runs out. I can still play single player just fine but playing with friends is impossible now. I’m not sure how to track down the source of the problem, so now I come here.

Check your firewall, make sure it isn’t blocking gmod nor steam.

A friend of mine had this issue, he managed to solve it by setting -dxlevel in the launch parameters. I am unsure of what he set the dxlevel to however.

It’s not the firewall, the problem started after a specific update and every other multiplayer Source game still works, I can connect to servers on those games just fine. Smithy, if you read this, could you ask your friend what the number was? None of the ones I tried solved the problem.

I was sort of wrong, here is how he solved it;

http://forum.facepunch.com/showthread.php?t=1280968&p=41210434&viewfull=1#post41210434

http://forum.facepunch.com/showthread.php?t=1287278&p=41419022&viewfull=1#post41419022

He did both of them.

Thanks for the help, but after doing both, it still doesn’t work :S

Bump, I really would appreciate any help :smile: