Garrys mod doesn't work for me?

Okay, so I bought Garry’s Mod on Steam with the CS: S package, and from day one it hasn’t worked.

What basically happens is I try to start it up and I come to a loading screen (there’s a picture of a guy and some birds and the little Loading thing in the corner) I think everything is going to work out alright when the screen goes black for a few seconds, then only half the screen is black and a little error things pops up and says “hl2 has stopped working” so on and so forth.

I’ve tried Googling it to see if there was something I was missing or a kind of quick fix for it. I’ve been told I should uninstall/reinstall it and I have, but it didn’t make any difference.

I don’t know anything about this stuff so this could just be my fault, but if you have any kind of answers it would be appreciated. =]

Please post your computer’s specs.

Also, you have to run CS:S at least once to extract the required Source Engine files (if you don’t have any other Source games, that is).