Garry's Mod Freezing/Crashing giving me BSOD's

System hardware specs

  • Processor: Intel Core i5 @ 3.39GHz
  • RAM: 8GB DDR3 RAM
  • Graphics Card: MSI R5770 PMDIG (Ati Chipset) 1GB GDDR5
  • Operating System: Windows 7 Ultimate 64 bit

Addons you have installed

  • Advanced duplicator
  • Bridge Tool V2
  • Conna’s Tools Pack
  • District9 Driveable Vehicles
  • DoorSTool
  • Helicopter vehicle
  • HurtSounds
  • Jetpack
  • Keypad
  • Laser STOOL 2
  • Nuke Pack 4
  • RagMod
  • real dismembent mod!!
  • Stacker STool
  • Wiremod + Wiremod modelpack

I’m currently lagging and freezing when lots of props move (EG when I unfreeze a lot of props or make something explode) sometimes the game even crashes or rarely give me a bluescreen.

I looked for ages and I do not know what’s happening.

I know Gmod can’t cause BSOD’s but the weird thing is that my computer is ALWAYS updated due to MSI Live Update, but as I said it only happened once.

I also play in a window.

And my net_graph 5 says:

http://alphatrex.net/imagestore/SS-2011-01-29_08.02.30.png

http://alphatrex.net/imagestore/SS-2011-01-29_08.03.52.jpg

The reason: http://www.facepunch.com/threads/1054522-Garrys-Fails-at-programming

Make a picture of your specs with Speccy.

And what does the BSoD say?

I can’t remember, only happened once and it was ages ago. I’ll write it down next time it happens.
As for the specs:

http://alphatrex.net/imagestore/SS-2011-01-30_07.31.26.png

@ Fobaz
HL does have explosions too? They don’t lag me. (Of course it’s built differently, but you get my point I assume)