Garry's Mod "hl2.exe has stopped working" when joining a server! PLEASE HELP!!

Today i want to play GMod, when i join a server, it’s crashed. The Error is Hl2.exe has stopped working.

PLEASE HELP!! I WANT TO PLAY GMOD WITH MY FRIEND!!! :frowning:

EDIT: Single player and Multiplayer not works for me.

Same

Sometimes this happens. I’ve had it happen quite a few times in the past week, just try again until it lets you connect. If it wont let you connect, it could be a multitude of things from Addons, to ram, your video card, etc. If it refuses to let you connect and you have any custom addons, move those into a separate folder one by one and retry the connection until it doesn’t crash. If your addons aren’t the problem, you should try changing your configuration to DirectX 8. It’s very possible that your Hardware may not be compatible with Garry’s Mod. To do this, open steam and head to your library. There, right click on Garry’s Mod and click ‘Properties’. From there, go to ‘Set Launch Options’ and add -dxlevel 81 to the line. These are just what I think may help you, I’m by no means a professional.

What OS are you using?
hl2.exe are most occurred on Vista.

Hl2.exe has stopped working is a generic and common error, crash dumps would help.

Full Infomation of my SYSTEM:

OS: Windows 7 Ultimate
Processor: Intel® Core™ i3CPU 530 @2.93GHz 2.93GHZ
Installed RAM: 2 GB
System Type: x86 (32-Bit)
Windows is activated by Genuine.

That the all.

Also i test in singleplayer… not works at well. Also Multiplayer not works too :frowning:

Yeah... that's not even CLOSE to "Full" information on your system.

This is also happening to me. I have to delete the cache folder before joining, and each time the maps/server restarts, I have to keep doing the same thing. It’s honestly annoying. Also, sometimes this method doesn’t work.

EDIT: Go open the windows search bar, and type “dxdiag” (without the quotes), and there’s your full computer’s information

Try running Garry’s Mod in different dxlevel’s

Did it work before?

if your just joining a server and it crashes type this in console at menu: vgui_allowhtml 0 it worked for me

meanbaby’s solution worked for me too

Thank you meanbaby. Now I have Garry’s Mode again.

when im connected to internet its load post init system its crash when im not connected its work

hewlp me please!!!


(User was banned for this post ("dumb bump" - postal))

Necropost + unrelated.