Garrys mod is crashed

After the patch, I wanted to play garrys mod for one month, but it plunges off, there was only very briefly the picture but then it was black and it came the error: Engine Error no steam apps. But I have counter strike source, beta, Team Fortress 2 and l4d2. Everything installed and used. many have said I should delete the clientregistryblob but that has not worked. Reinstalling has not worked out so well, can one help me find the problem??. Thanks in advance.
sytem win7

Seems that you don’t have a profile on Steam… You got a valid link to your profile or what?

yes I have, but yes I bought the game via Steam, so I’m surprised something.

That’s odd. Verified the game cache files?

yes I’ve tried everything defragment, reinstall the product, everything but nothing helped, that’s crap. There are also a few people that have the same problem as me, but until now no one knows exactly how I solve the problem. -.-

System Specs?

Is all right, nothing defect or something.