Garry's Mod is Crashing at Sending Client Info or whenever the server loads in.

So Recently I’ve been dealing with Garry’s Mod Crashing at Sending Client Info or Whenever the server starts to load in stuff such as MOTD’s and whatnot it would crash there.

I’ve Tried:
Verifying Game Cache
Unsubscribing all Garry’s Mod Addons and reinstalling them
Making Sure I have the content pack for the server.
and Updating Drivers

It worked fine 4 weeks ago but now it’s decided to start crashing at Sending Client Info or whenever the server starts actually loading in.

Crash Log: https://pastebin.com/0d7qMe6d

Specs:

Operating System
Windows 10 Home 64-bit
CPU
Intel Core i3 4170 @ 3.70GHz
Haswell 22nm Technology
RAM
12.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Motherboard
HP 2B5B (SOCKET 0) 28 °C
Graphics
Acer K272HL (1920x1080@60Hz)
SONY TV (1080x1920@59Hz)
Intel HD Graphics 4400 (HP)
Storage
931GB Seagate ST1000DM003-1ER162 (SATA)
Optical Drives
hp DVDRW DU8A6SH
Audio
Realtek High Definition Audio

I had the same problem, i found out that the TF2 update broke GMod, unmount your TF2 by pressing the controller icon (bottom right in the menu) and uncheck TF2 then restart.

EDIT: Subscribing to this should also work, this is only a temporary work around though. http://steamcommunity.com/sharedfiles/filedetails/?id=1175610041

Hope it works.

That mini dump does not help us. You need to upload it to dumps.metastruct.uk.to, so we can positively identify the cause of your problem. However, the problem most likely is running PAC3 being run on servers combined with TF2 being mounted on the client. Tell the server owner to update his PAC3 through the Git or SVN. If you are the server owner, then update it.

Here you go
http://dumps.metastruct.uk.to/dumper.py?dump=assert_hl2.exe_20171027185649_1.dmp&key=nJjVvpH64e2pwVSGBt0LFjPP79USedRlLVjmIJcCTDZnHw3PjUdp7WpXtco_NGW4e8j1UwCqQVPFPwXpKXc5qPjkYDJ3GtpRuoNM5jCVqSKY3KpbbD6gqo2ijM6dF1NhLy9DlzRgL6veHQ6d8Uewd0Y5BEijyvvHoffk98xBN9o=