Garry's Mod is Destroyed

Garry’s Mod is fucked up to an extreme. The spawn menu/“C” menu won’t open when I press “Q” or “C”. The skybox is missing in gm_construct. The Physgun is just showing Gravity Gun animations. The weapon selection is missing section 6, and in section 1, there are a bunch of blank spaces with the words “PRINT NAME”. One of the "PRINT NAME"s when opened, is the Toolgun without any text on the screen.

None of these problems appeared until Steam started updating. None of the problems appeared until I put a custom skin into the game for a few props (probably has nothing to do with the errors, maybe just a coincidence).

Here are a few screenshots for proof:http://imgur.com/a/KSKyu#0

EDIT: Before any of you say it, I tried binding “Q” to “+menu”, but the console said “+menu” was an unknown command.

I am having some problems too now after the latest update, i can’t even play single player, my server’s Day and Night script doesn’t function correctly anymore and Grav guns don’t function correctly either.

Thanks for killing your own game, Garry…

Fuck you nigger


(User was banned for this post ("Dumb racist flaming." - postal))


(User was permabanned for this post ("extended, came back on an alt to shitpost more" - postal))

I have a serious problem as well, everytime I load a map there are missing textures, spawnicons aren’t loading at all, and I can’t load saves.

Also appears that none of my legacy addons are working either.

I have tried restarting the game and remounting games, none of it has worked.

All of the addons I have are models, tools, and enitities that I use for posing

Have you tried reinstalling gmod?

Well I fixed most of my issues by uninstalling a few defunct workshop items, also turns out that Dusbowl2, the map that was having the missing textures that I got from workshop was uploaded to workshop WITHOUT the custom textures from Dustbowl1 with it. But the other map I played, GM_Valley is also having textures problems and that only requires Half-Life 2.

I wonder if this has to do with your current OS, because i’m using windows 8 and it works just fine. My friend on steam who’s complaining about it not working is using windows vista.

Dumb nigger got banned, teaches the stupid racists right. I bet he’s a black too.


(User was permabanned for this post ("gimmick" - postal))

oh my god im dying