Garrys Mod - Joining Server Problem

Hey all, Since the latest update i have been getting problems with joining servers. When i join a server and download the files it freezes on the last download and if i have the files it would stay on contacting server info with only five bars left, please help!

I’m also having troble with joining servers
I will download every thing and then go on and see the map and every thing for about 5 econds then it says reconnecting and then failed to connect after 4 times or something like that

I am also getting this problem.

But instead of just stating it we should post our system specs.

CPU: Dual core intel 1.8 ghz
GFX CARD: 256mb intel express (It’s a laptop!)
RAM: 2 GB DDR2
OS: Windows Vista Home

The problem is that when i try to join a server it gets to “sending client info”
then just stays there for about 10 minutes then the spinny thing starts spinning again and it just spins forever.

Help would be much appreciated.

Same thing with me, In my thread i have put what it says in my console.

Ps. i don’t want to stary a debait, but does evrybody else with this error have vista by any chance?

Reinstalling didn’t help.

We need a fix Garry!

Or atleast a temporary fix.

What happens with me is that the server loads painfully slow now. So much so that every time I try to log into a server I always get the “user timed out” message.

I freeze up when I get down to one file to download,
but I don’t have to exit gmod or anything, it just takes about 5 minutes for me to join a game…
>:P

Yeah, Dragon, REAL SLOW.

Same exact thing is happening to me aswell, I made a thread about it. I hope this gets fixed soon.

Ps,I am not using Vista.

I’m new to the forums (joined today lol) and I was going down the list, and I saw this… I got the similar problem, except the only difference is that when I try to join, it says my GMOD9 version does not match the servers, but I DO have the same version (9.0.4.) and I started gmod9 recently, and I’m GOING FUCKING NUTS, because I’m a newbie and I need other people’s help and all… lol

If Any of you find any answer, please post it here… lol

I have this exact problem! I join a server and it loads normally, but when it reaches Sending Client Info, it freezes for about 6 minutes. Then the orange dots continuously spin around the G logo and nothing happens, forcing me to disconnect. A fix would really be appreciated. :frowning:

Same thing happens to me it loads very slow until the point were I’m about to exit. Then it goes to “Sending Client Info” and it freezes up. By the way if it helps, I’m using VISTA Home Premium.

Lol, I joined just to get a fix for this stupid problem. I’ve got the exact same problem.
I’ve got vista home, but thats not it, because its worked for ages before hand. But yesterday i got a new modem, and suddenly my gmod is stuck on sending client info, with 3 rectangles to go. Maybe thats whats wrong?

Someone find a fix soon, i miss gmod

I’m guessing it’s your internet connection.

I dont think so…All my other games work with my new modem, but this doesnt. Im going to have a go at deleting gmod tonight, and reinstalling.

I’ve gotten the same problem, it turns out is somthing to do with addons, I think it has to do with having a large ammount of add-ons myself, also, I moitor my CPU usage and RAM usage while loading, and the ram usage jumps from 63% back down to 50%, and repeats this indefinatly, I have 4 gigs of ram and a bit more then 10 addons if that helps

That’s a good point. Remove addons :D. I’ve deleted gmod, starting again.

dont bother, it didnt work. doesn’t anyone want to report this to garry or something?

I am having the exact same issue with not being able to connect to a server. It starts to send the client info, three bars are left, and the connection times out after awhile. I downloaded the latest version of wiremod, and that is not fixing it. It only happens on a few servers, Mainly my clan’s Spacebuild server. Strangely enough, I could connect to my friend’s Spacebuild server that he used. I tried deleting my cache, that did not work. I think it has something to do with another addon, but I am not positive.

I think its either Wiremod or PHX. I’m thinking PHX, because gmod seemed to stuff up only after I installed it.

EDIT : I don’t know if this will help identify the problem, but here are two records of the console after it got to the point where I could cancel, but it still wasn’t working.

ONE

Garry’s Mod server.dll Build #049 [Sep 18 2008 12:38:48]
maxplayers set to 1
Unknown command “sv_backspeed”
GetAllManifestFiles: Unable to load maplist.txt
Network: IP 192.168.0.127, mode MP, dedicated No, ports 27015 SV / 27005 CL
Connecting to 124.169.52.69:27015…
Connected to 124.169.52.69:27015

Sandbox
Map: gm_flatgrass
Players: 3 / 8
Build: 3575
Server Number: 1

No pure server whitelist. sv_pure = 0
Error! Variable “$reflectentities” is multiply defined in material “phoenix_storms/glass”!
material phoenix_storms/train_wheel has a normal map and $basealphaenvmapmask. Must use $normalmapalphaenvmapmask to get specular.

Error: Material “models/weapons/w_minigun/w_minigun01” : proxy “weapon_invis” not found!
Error: Material “models/weapons/w_minigun/w_natasha01” : proxy “weapon_invis” not found!
Error! Variable “$bumpmap” is multiply defined in material “phoenix_storms/metal_wheel”!
KeyValues Error: LoadFromBuffer: missing { in file materials/metal4.vmt
(LightmappedGeneric_DX9_hdr),

TWO

Sandbox
Map: gm_flatgrass
Players: 1 / 12
Build: 3575
Server Number: 1

No pure server whitelist. sv_pure = 0
Lua initialized (Lua 5.1)
======== Beam NetVars Lib v0.71 Installed ========

Simple Prop Protection Version 1.5 by Spacetech has loaded

=== Loading Wire Menus ===
======== Installing Table (De)Serialiser Module | ver: 1.4 ========
==== Advanced Duplicator v.1.72 shared module installed! ====
==== Advanced Duplicator v.1.741 client module installed! ====
=== Loading Wire Model Packs ===
Loaded: PHXWireModels.txt
Loaded: default.txt
Adding Cheeze’s Buttons Pack
Jaanus’ Thruster Pack
loading materials
loading material: cable/rope_icon
loading material: cable/cable2
loading material: cable/xbeam
loading material: cable/redlaser
loading material: cable/blue_elec
loading material: cable/physbeam
loading material: cable/hydra
loading material: arrowire/arrowire
loading material: arrowire/arrowire2
— Missing Vgui material modelsduckehuttons
Registering gamemode ‘sandbox’ derived from ‘base’
Loading Wire Tools
Sending 997 ‘User Info’ ConVars to server (cl_spewuserinfoconvars to see)
This is where it froze, is it that it can’t send the user info? I’ve no idea myself.

Maybe someone can figure something out from that?

Same thing with me!!!

It’s wiremod.

You can remove it until Garry updates Gmod in a few days.