Garrys Mod just WILL NOT START

Ok, I’m just gonna get the system specs out of the way here:
Processor: Intel Pentium Dual Core E5200 @ 2.5 GHz
RAM: 6 GB (but only 3.25 usable according to Windows)
Graphics: XFX NVIDIA GeForce 9500GT (1GB)
OS: Windows 7 Ultimate 32-bit.

No Addons, clean install

Now the problem:
I have played GMOD on this OS before, but the recent updates this past month have completely messed everything up. After the latest update, I tried to run the game, and after I get past the preparing to launch Garry’s Mod, my icon in the bottom right corner changes from blue to green (showing a online to in-game change) and nothing happens. After around 5-6 seconds, it goes back to online mode, and not in game. I uninstalled, deleted the garrysmod folder (making sure that it wasn’t an addon problem), and reinstalled the game. I have tried to use both DirectX level launch options as well as the -fullscreen option.

Can anyone help me out here?

Is there a DEP exception for Garry’s Mod?

I turned DEP all the way off (through command line), so I don’t think that’s the problem. I have played GMOD before on this system, DEP isn’t the problem.

I tried something just today, go to your garrysmod directory and go back one foldier, there should be a bin file full of stuff that is the engine, delete it and redownload(or just hit play like i did)

Verify game cache

Also, the reason for only 3GB RAM showing up in windows is becuse you have a 32 bit OS, 32bit can only take 2^32 bytes of memory (4GB) and like 0.75GB is reserved for hardware and other crap

Thank you sir, that worked perfectly! I needed my fill of GMOD!