Garry's Mod Keep Redownloading Mods After Restarting the game

Recently I’ve been having an issue with Garry’s Mod where several of my addons will not fully download and attempt to every time I restart the game. I have exactly 104 addons and upon a direct reinstall it will download all 104 addons as expected, but upon restarting the game, it attempts to redownload 64 of them. I previously asked for help on a different forum and was redirected here for further help with this issue. It can also be noted that within the steam’s download manager, it constantly says that it is updating workshop content, even though it never makes any progress at all.

This is my previous post where I could not find help, incase it helps to clear anything up.
http://steamcommunity.com/app/4000/discussions/1/1471966894879097394/

Can you check the console after it tries to re-download the 64 addons? An error may be coming up on the console.

I’ll attempt to do it again and post the console

[editline]30th July 2017[/editline]

I haven’t tried every single one, however this should give an idea of what’s happening.

Initializing Awesomium…
No Kinect SDK
Unknown command “prophunt_kill_hpgive”
Unknown command “prophunt_hunter_blindtime”
Unknown command “prophunt_gametime”
Unknown command “elev_slapforce”
Unknown command “elev_cooldown”
‘Re:Zero Rem Playermodel’ is missing Addon, ServerContent, Dupe, Demo or Save tag!
Addons have changes - remounting
— Missing Vgui material vgui/crosshair_bg
Transferred 41.5 MB (43561322) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Cancelling workshop download… too slow… maybe stuck? Try again later.
END: DownloadAddons
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Cancelling workshop download… too slow… maybe stuck? Try again later.
END: DownloadAddons
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Cancelling workshop download… too slow… maybe stuck? Try again later.
END: DownloadAddons
Transferred 398.7 KB (408254) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Transferred 0 B (0) in 10 seconds
Cancelling workshop download… too slow… maybe stuck? Try again later.
END: DownloadAddons
Transferred 0 B (0) in 10 seconds

[editline]30th July 2017[/editline]

I also didn’t realize this till now but after I posted that, I got several errors all saying

Error downloading file! - Error Code 37

Where is your game installed? Full path? Wheres your Steam installed?

I seam to have a similar problem, where the addons will either get stuck at 100% or 0% download and won’t extract. The console says a similar message. Yesterday I subscribed to a servers collection and it was doing that up to a point when after restarting the game multiple times it ended up extracting everything directly.
I think steam downloaded the contant in the backgroud and gmod didn’t seam to notice that was the case untill the downloads were all done at which point restarting the game made it notice the content was downloaded and it only had to extract ?

Also, when I subscribe to only a single addon, it does the same (Usualy goes to 100% download and then get stuck with the Transferred 0B (0) in 10 seconds message), and I need to unsubscribe and resubscirbe to it to make it extract.

If needed my steam is installed on C:\Program Files (x86)\Steam and my game is on D:\Steam\steamapps\common\GarrysMod\

Yeah there seems to be a problem with GMod if it is not installed on the C:/ drive for some people.