Garry's Mod Lua Error "Not enough memory"? Please help!

Process: hl2_osx [752]
Path: /Users/USER/Library/Application Support/Steam/*/hl2_osx
Identifier: hl2_osx
Version: ???
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: hl2_osx [752]
User ID: 501

Date/Time: 2015-07-29 15:22:42.928 -0700
OS Version: Mac OS X 10.10.4 (14E46)
Report Version: 11
Anonymous UUID: E347149B-D014-9525-7034-AB9AEE39F441

Time Awake Since Boot: 13000 seconds

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/libtier0.dylib
Referenced from: /Users/USER/Library/Application Support/Steam/*/hl2_osx
Reason: image not found

Binary Images:
0x8fe84000 - 0x8feb7e03 dyld (353.2.1) <D62B782E-02ED-373D-9AD3-6D14E4FE35A3> /usr/lib/dyld
0x9b725000 - 0x9b726fff libSystem.B.dylib (1213) <21396191-7FE2-398E-9DC3-0CA1DDC43EEE> /usr/lib/libSystem.B.dylib

Model: iMac14,1, BootROM IM141.0118.B09, 4 processors, Intel Core i5, 2.7 GHz, 8 GB, SMC 2.14f24
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3430554738454655352D474E4C2D46
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3430554738454655352D474E4C2D46
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x111), Broadcom BCM43xx 1.0 (7.15.166.24.3)
Bluetooth: Version 4.3.5f8 15969, 3 services, 27 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE HDD ST1000LM024, 1 TB
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: FaceTime HD Camera (Built-in)
USB Device: USB Optical Mouse
Thunderbolt Bus: iMac, Apple Inc., 23.10

Platform: iMac OSX Yosemite 8 GB 1600 MHz DDR3

[editline]29th July 2015[/editline]

Engine Error?

Lua Panic! Something went horribly wrong!

“not enough memory”

getting the same error, i really need this fixed

I belive this is a windows 10/mac problem, I fixed it by uninstalling all TDM cars.

Only the tdm cars and did it start working fine for you?

You should consider getting a windows pc 7 or 8.1 preferably make sure you get a 3.00 GHz processor or higher and 8GB ram at the least the not enough memory won’t happen as RediL said it is a windows10/mac problem and the specs I have given you will provide you amazing framerates also. :happy: