Garry's Mod Menu Branch Problem

Hello,
I had sent a ticket to FacePunch Support’s website, but never got a response since (not even an assigned agent), so I’ve decided to ask about my problem here. This problem has been happening since last year, but I figured some updates would fix them. I was wrong. My problem is this: Once I play Garry’s Mod on Steam, it loads normally and then the Menu is there. So this menu, it has black text, and it looks nothing like the average menu.
It says this (yes, I have images available):
You are on {{Branch}} branch. Click here to find out more. ({{Version}})
Then there’s a small green arrow I can click, but doesn’t do anything.
The game controller you see, I can click but doesn’t do anything.
Those square and circle buttons, I can click, and it turns blue, but it does not do anything.
So my problem, does not let me play Garry’s Mod, at all. It’s been this way for months, but I finally decided to ask again about it in a thread. I have tried everything I’ve seen online from searching this, and more, which includes verifying cache files, reinstalling, changing the [dev] mode (both ways), and restarting my computer and such.
I have no idea what else to do, I’m lost, and I’m hoping there’s a solution.
I have a MacBook Air, updated to its latest. I would like a response soon.
Images:
http://prnt.sc/a3ou2b
http://prnt.sc/a3ouee
http://prnt.sc/a3ouj4

Thank you, in advance.

You can use this for now:

Should I merge or replace the original lua folder with the one you suggested?

Do you have a controller enabled? If so, disable it. If not, try validating and/or reinstalling gmod.

By controller, do you mean a game controller? If so, no. I’ve already tried validating and reinstalling Gmod, several times. I’m currently being assisted by a FacePunch Support employee, though, but we haven’t found a solution yet.

Looking at the pics, I am guessing this is a problems with your pc. Maybe your pc doesn’t have the requirements to run the game? The purple and black texture usually means that you don’t have the texture or the texture isn’t loading.

Actually, recently, the menu has been showing those images that transition and sort of move (the usual ones). I’ve definitely checked my requirements, and the game did work before.
Recent image:

Hey, I reckon your menu is hitting a JavaScript error. Could you enter “-condebug” (without quotes) in to your game’s launch options and supply us the created “console.log” file?

Here’s how to modify the launch options: https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947

After running the game, console.log should be created in SteamApps/common/garrysmod/garrysmod/console.log. You can either post a link to it here or just PM me.