Garry's Mod not loading past first screen?

So, my mate bought me a bunch of games a couple of days ago because I’m in a foreign country at the moment…
2 of the games he bought me were “Portal” and “Garry’s mod”. And of course i already had TF2. I’ve been playing TF2 for ages without an issue, and finished Portal a couple of days ago without issue. But when I tried to boot up Garry’s Mod, it wouldn’t work. At first, I thought it was just taking ages to load, so i let it do its thing. After a bit over 10 minutes it went back to the desktop with it saying that “hl2 has encountered a problem and has to close”. I thought it would just be a one-off problem, but after many launches the only thing I’ve achieved is for it to close sooner. I thought it might be the engines problem, so I went into portal to see if that would mess up to, But Portal and TF2 are working fine. I’m using Windows Vista. After reading through a couple of other posts i found http://www.garrysmod.com/2011/03/12/crash-dump-viewer/ and tried that, but the only dump folders i have are a couple of TF2 problems… Help please?

Ask the Help/Support section.


(User was banned for this post ("Thread-shitting/backseat moderating in multiple threads." - postal))