Garry's Mod not starting up right

I updated Team Fortress 2 to the SteamPipe today after not playing it for a good couple of months and now GMod isn’t able to start up.
When I play it, it switches to a low resolution fullscreen, flashes black and white, and then quits.
I had the launch settings to both be -noborder -w 1600 -h 900 +developer 4, then I changed it to -autoconfig +developer 4

I’ve already restarted steam, then deleted the two .blobs and restarted. Neither worked.

Just dealt with a problem like this, And another about a month ago:

Their solution: Re-install everything (steam, all steam games) since they haven’t played gmod in a long time (few months), Thats when the problems happened.

Try that as a last resort however, Cause it must be painful to re-install all of your steam games :stuck_out_tongue:

Try taking off the launch options (Unless you put them on there to fix it), Re-install garrysmod first if that doesn’t work re-install your entire steam (Delete your steam folder, ENTIRELY and re-install).

So many people seem to have that problem, I guess it’s because garry’s mod doesn’t update quick enough then breaks.

I’ll at least have something to do over the summer. Yes, it is a pain :slight_smile:

The first set of launch options were there before the problem. The second set is what’s suggested off the support page (-autoconfig). +developer 4 is just nice to use, I like verbose.

It doesn’t seem like L4D2 is starting correctly either. It may be a problem with Steam, then, or the way the new source engine shit is handled.
Deleting everything but steamapps, will report back to whether it works or not.

My cousin was having this issue. Verifying Integrity fixed it perfectly fine for him.

Apparently steam is very hard to reinstall! Ran through dozens of errors trying to repeat opening Steam and SteamTmp until SteamNew finally started downloading an update.

Neither solution appeared to work. Going to have to see what’s causing this, then?
aye, whered that dump site run off to when you need it…

Ah, the problem was that the Windows Update uninstalled my video drivers when trying to install new ones. That update failed, and so did trying to install it manually (the setup from nVidia’s drivers page, 320.18).
Will attempt to install the beta drivers, editing to respond.

[editline]edit[/editline]
Guh… had to roll back to the last supported driver I had. 260.99
If anyone can help me with this, you may. Every other installer is giving an NVIDIA Installer Failed error at System Check

[editline]edit[/editline]
NVIDIA’s logger noticed this (huh. feels so much smoother in safemode than native res.)

[editline]edit[/editline]
260.99 reinstalls successfully after uninstalling NVIDIA Update. Will uninstall again and try out 320.18

[editline]edit[/editline]
Ok, now I’m just confused. Got back from eating, and a notification shows that a device is ready to use.
Now the driver version in the Programs and Features are at 311.06

(Moved to tech support forum this is very interesting to me)