Garry's Mod Not Working Properly

This is a new type of error that’s happened, I’ve never seen anything like this, and asked someone who’d have more experience - New to him too. Anyway background: I wanted to play TTT, joined a server and it didn’t DL the files, so I tried some things, made sure “Allow all custom files from server” was enabled and remove the cache folder, then after much failure I removed GMod. It’s when I reinstalled it again that this happened, this weird mutated GMod. Here’s some screenies and a log of the console after I pressed each button in the main menu excluding the “Exit”. You can find the console log here

The loading page is functional and the little balls do spin, like I was starting a game/joining a server

From the Unknown command: "menu_multiplayer, i have to ask, have you updated gmod in the last day or two? If not, thats your problem. Garry accidentally broke the menu and fixed it a few days later. Just update your gmod if you havent already and itll be fine.