Garry's Mod Ports and my router. Why they hate each other. (Actiontec MI424-WR_Rev.E)

Well the problem here is simple I enter the correct ports and the game won’t let me host a listen server for my friends. I don’t want a dedicated server as its too much hassle for just a few games. But I still would greatly appreciate if some one could help me out with the similar router. (Verizon FiOS one) I have actually got it to work by opening all my ports on my static ip. But I dont want them all open… So its possible to make it work just I need to know the right ones.
Here are my firewall settings and then my port forwards.
http://img35.imageshack.us/img35/3725/router1n.png
http://img834.imageshack.us/img834/2811/router2.png

I’m hoping you how to navigate through the routers web panel, try creating a custom application rule and just open port 27015 on TCP and UDP.

If you are unable to find, or make a custom rule maybe I can offer some help over a skype or steam chat, or if your comfortable a remote desktop session with TeamVewer.

I did, but no luck. It will not show up in my Local Servers when I host and also no result on the internet servers either.
I know that I have to open another port other than 27015 TCP and UDP. Seeing as when I opened all my ports, TCP and UDP the server worked in Local and Internet functions. I also try the commands

  1. Ip (My IP)
  2. sv_lan 0
  3. Heartbeat
  4. Step one again.

and it doesn’t work… I already have reinstalled Gmod and cleared my router…
I just need to know the specific Garry’s Mod ports.

[editline]6th February 2011[/editline]

Well I ended up forwarding these ports Half Life 2 Steam Server TCP: 27014-27050 UDP: 4380, 27000-27030
And I thought if I start it as a local server then I can do all the commands to switch it to an Internet server that might work. I tried it and Yes! It does. I also changed maps in Console and then checked.

So this is Solved!