Garrys Mod server, guns ammo not depleting and not giving damage

Hey, I turn to FacePunch today in the hope you can help me.

We’ve hit a snag in our progress, and I have no idea how to fix it. Being a newbie I’m not very advanced or fluent in the LUA language.

What happens is:

When you shoot, your ammo goes down, and right back up again, it does a small animation of you reloading, just the start of it, then it lets you shoot again. You can still get the machine gun effect.

Other users see the gun as being held down in your hand, with your arms straight down against your leg.
When you shoot, they do not see it, and are not damaged.

Guns do not deal any damage to NPC’s either.

Roleplay gamemode, I’ve tried many gamemodes, DarkRP, Cider, Kuroscript.
This is not a client-side problem. I believe my dedicated server (cubosgaming.com) is glitched.

Any help or words of advice?

PERP leaked?
Remove it.

Im not sure if it was PERP, just something I got off gmod.org. (I look now and its removed, probably a fake edit)

Do you have any answers?