Garry's Mod Server not Starting (back at it again with the white vans)

Hey guys, it’s me… can you… no…
craniel is back with his problem: GMod TTT srcds server not starting on my win10 computer…
It is starting on a win 7 pc with a better processor (i don’t think, this is causing the problem)

The server is located at “C:\Server\Source\crazy TTT(srcds.exe)” and if I start it through the watchdog (crashhandler), it dumps some unreadable mdmp crash files and a wierd, very short readable console text:
DOWNLOAD
CONSOLESCREEN

I also have Counter Strike Source as a resource for the TTT server at “C:\Server\Source\CONTENT\Counter Strike Source(srcds.exe)” which starts propertly if I edit the shortcut to the srcds.exe with the tags:


-console -game cstrike -insecure -maxplayers 22 -map de_dust2

SteamCMD is located at “C:\Server\TOOLS\SteamCMD(\steamcmd.exe)” and the server and CSS is updated through a bat (“update CONTENT.bat”, “update crazy TTT.bat”) with this codes:


""C:\Server\TOOLS\SteamCMD\steamcmd.exe" +force_install_dir "C:\Server\Source\CONTENT\Counter Strike Source" +login anonymous +app_update 232330 validate +quit

This is the code for updating TTT:


""C:\Server\TOOLS\SteamCMD\steamcmd.exe" +force_install_dir "C:\Server\Source\crazy TTT" +login anonymous +app_update 4020 validate +quit

The start code of TTT:


@echo off
cls
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait srcds.exe -console +game terrortown +map gm_construct +maxplayers 16
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

CSS is mounted through the lua “C:\Server\Source\crazy TTT\garrysmod\cfg\mount.lua”:


// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
"mountcfg"
{
"cstrike"	"C:\Server\Source\CONTENT\Counter Strike Source\cstrike"
}

I think it’s a problem with some dll’s or so…
Thanks for any new helping help xD
craniel

You seem to be crashing in Steam API, is Steam launched on your PC when you start your server?

Steam is launched when my PC starts.
But you don’t need steam for a server?
You only need SteamCMD, right? :smiley:

Try closing Steam and SteamCMD if you have it open for some stupid reason.

I’ll try
Not working :confused: