Garry's Mod Silently Crashes At Start.

The title says it all: I start Garry’s Mod, and it silently crashes. Plain and simple.

We’re going to need an error.
There isn’t one. That’s what SILENTLY means.

Seriously, we’re going to need an error.
Seriously, there ISN’T one.

What are your specs?
Unless Garry actually put us on the L4D engine and I’m not aware of it, my specs are not the issue at hand here.

Try deleting ClientRegistry.blob
Steam knows I own the game, besides, if that were the case, it’d give me an error similar to “U DUN OEN ET”



-window -heapsize 524288 -nocrashdialog


Try running those boot options.
Do you hear that “Bing” sound when something pops up?

Already windowed, and there was no noise. No nothing.

Also, why would I need to suppress a crash dialog that does not appear?

[editline]10:51PM[/editline]

Also, heapsize is fail. Same results

You have an fresh install of gmod?
Or could you play, and did this just started happening?

It ran fine…day before yesterday? Something like that.

And today it just goes boom every time I try.

Try adding either:


-dxlevel 90

Or get rid of -windowed and add


-fullscreen

My DX level is already at 9.0.

And something tells me fullscreening it will not help, since it’s not even initializing properly before it starts rendering shit.

[editline]12:09PM[/editline]

Doing the “garrysmod.old” trick seems to have fixed it - I’m assuming I’m missing a DLL in the old folder somehow.

The fullscreen trick worked for me, and I had the same issue.

What is (probably) the difference is: You guys get a “transparent box” (window borders) right before silent crash, I don’t even get that. It’s something that happens BEFORE rendering takes place. If it wern’t for the fact that it usually says “Preparing to Launch”, I’d think I never even started it.

I wound up having to rename garrysmod to get it working again.