Garrys Mod; Spacebuild 3: What am I doing wrong?

Hi

I’m have been playing GMod for some time now and i just recently installed the Spacebuild 3 Addon with all its components. While playing in the Spacebuild gamemode life support is an essencial part, and this is where the problem takes action.
Whenever i try to spawn a generator or a climate regulator and turn them on (oh yeah, solar panels actually do work so dont blame insufficient energy), they automaticly turn themselves off.

Ex. Solar Panel, Oxygen Compressor, Resource Cache, Air Exchanger --> Node --> Vehicle
When i turn them on, the only things that doesn’t turn themselves off again is the Solar Panel ( i exclude the Node and the Cache for some obvious resons)
Am I linking the stuff wrong? Is something missing?
Forgive me for being noobish, but you simply cant help it sometimes :wink:

I almost forgot.
I have the following addons installed:
Spacebuild 3
Life Support 3
Resource Distribution 3 (and 2 since an error told me to install v2 too for some reason. It doesn’t work at all without RD2)
Custom Addon Framework
Some random Model Packs
Spacebuild Enhancement Project

I’m assuming that you linked everything to the resource node. It sounds like you have power, but you may not have ENOUGH power. Try increasing the size of your solar panel, or add another panel. Your solar panel doesn’t take any energy to run; it’s providing the energy. It will only turn off when it’s not receiving light.

Also, once you’re comfortable with setting up your life support, you may want to consider fusion reactors. They run primarily off of plain water, and produce MASSIVE amounts of power.

Problem solved. It was some random lua from the RD2 that messed things up. Everything works now exept the fact that hydrogen and nitrogen compressors dont generate any resources. No biggie though since those resources isn’t used to very much.

Btw, a giant solar panel generates extremely much energy, so energy couldn’t have been the problem anyway :wink: Thanks for trying to help though :smiley:

Im sorry for posting in this old thread, but I couldnt find the answer.

So anyway, I found the answer and will share it with you to save you searching for hours and hours…

Go to addons folder, make sure you have RD3.
Find RD2, and delete it.

Thats all, Again im sorry for posting in an old thread but this is just to save you searching for hours like me!

Shadishow

How the fuck did you fix it? I need to know.


(User was banned for this post ("Dumb Bump" - Mezzokoko))