Garry's Mod SteamCMD Server Help

Okay so I am getting really mad about this now, so hopefully you guys can help me out. So I used to run this server before but we got a new Belkin router and it’s not working anymore. I have the ports 27015 TCP and UDP and 27020 TCP forwarded, my firewall is off, I have sv_lan set to 0, I’ve typed in heartbeat, and sometimes when I run it I get this;


WARNING: Port 27015 was unavailable - bound to port 27017 instead
WARNING: Port 27020 was unavailable - bound to port 27021 instead


I’ve tried everything! Could it be that I’m using a belkin now, or am I doing something really stupid that I haven’t figured out yet. Also, the only other server I have is my Minecraft one. Please! Any help would be great! :pwn:

Just open ports 27015 - 27030; if the ports rebind, it means another program is using them.

It’s still giving me this though

Do you run any other servers?
try to run a netstat or something and see what is using port 27015 and 27020

It is good advice to open a wide range though, those are just warnings as it just incriments the ports to try to resolve conflict.

Try tools like http://www.yougetsignal.com/tools/open-ports/
to test your port to be 100% public can access it.

I get that, so open ports 27015-27030. If you have Steam open at the same time of running your server, that’s probably using the ports.

Alright, that could be it.

[editline]19th December 2013[/editline]

Alright guys I fixed it! My IPv4 Address changed somehow, and I changed my port forwarding to just 27015 TCP and UDP. Thanks for your help anyways! :smiley:

If you don’t want your local IP-address to change again, follow this guide: Static Local IP-Address Guide
Note: The site is a complete pain in the ass to read, but it’s worth it =)

http://puu.sh/5HGzO

http://puu.sh/5HGAj

http://puu.sh/5HGBd

Did this just go over your head?

http://puu.sh/5R6aV.png

Just report and move on; there’s no reason to spam threads with it. Also, you didn’t even point him your correct section. This wouldn’t go in Dev Discussion.