Garry's Mod stuck on initial Loading Screen. HELP!

I have an Alienware Aurora with a 2.8 GHz i7, Windows 7 64-bit, dual ATI Radeon 5670s in Crossfire, 9GB of RAM, I and have AVG free antivirus.
Everytime I start Gmod up it shows the back of the guy and says loading in the bottom right corner, but it stays there FOREVER. I have Deleted the local content of Gmod, verified the cache, tried using -dxlevel 81, defragged it, manually deleted the garrysmod foler, deleted the GCFs for it, source, and half-life 2, tried running it in windowed mode, reinstalled it, tried it with crossfire on and off, and it still has the exact same problem. Can someone please help D:

Have you mounted a lot of content like L4D last time you ended the game? Has it ever started up?

I dont think I “mounted” any new content. I believe you mean like valve games correct? All I have installed by valve is HL2. The thing is I havent played Gmod in a while and I cant remember If It ever ran on this computer, but im pretty sure it has.