Garry's mod stuck on loading screen, at the end of my rope.

Machine name: XPS-410
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Dell DXP061
BIOS: Phoenix ROM BIOS PLUS Version 1.10 2.3.1
Processor: Intel® Core™2 CPU 6300 @ 1.86GHz (2 CPUs), ~1.9GHz
Memory: 4096MB RAM
Available OS Memory: 4030MB RAM
Card name: ATI Radeon HD 5450 1 GB

I’m literally at the end of my rope, I have tried everything to fix this problem. It started when I got a new computer for christmas, it was loaded with win 7 64 bit, and I reinstalled all my stuff and when I tried playing gmod, it got stuck at the loading screen with “loading…” bar in black in the lower right corner, and my cursor that little blue circle.

I had to end process it, because it becomes unresponsive. I’ve looked at tons of forums, and I found this http://forums.steampowered.com/forums/showthread.php?p=20405033, that shows others having my problem, and they’re also on win7 64 bit.

I’ve tried
-Updating drivers.

  • dxlevel 81/90
  • -fullscreen
  • -novid
  • deleting client registery blob
  • reinstalling gmod 5 times
  • reinstalling HL2
  • left it running to see if it’d eventually do anything, for an hour and it did nothing.
  • made sure it was an exception in my firewall
  • verifying game cache
  • defragging

I would say update your drivers, but you already have. Make sure your drivers are for a 64-bit windows 7. 32 bit drivers won’t work, or if they do, they will be very buggy and probably cause a lot of issues.

I’m unsure if my drivers are correct, that sounds about right, how can I check if I have the right drivers etc.