Garry's Mod with Source SDK Error(s)

Hi, I’m using Garry’s Mod with Source SDK and I’m getting some errors. I’m not sure if this thread would be allowed but it’s somewhat Garry’s Mod related so I figured I’d try.

When I try to run the map all I get is a massive dark screen. I’ve tried adding lights and it still nothing.

The compile log is as follows:

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\orangebox\bin\vbsp.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\compmemlab\garrysmod\garrysmod” “C:\Program Files (x86)\Steam\SteamApps\compmemlab\sourcesdk_content\Garrysmod\mapsrc\Practice1”

Valve Software - vbsp.exe (May 19 2009)
2 threads
materialPath: c:\program files (x86)\steam\steamapps\compmemlab\garrysmod\garrysmod\materials
Loading C:\Program Files (x86)\Steam\SteamApps\compmemlab\sourcesdk_content\Garrysmod\mapsrc\Practice1.vmf
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
**** leaked ****
Processing areas…done (0)
Building Faces…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (0) (584 bytes)
Placing detail props : 0…1…2…3…4…5…6…7…8…9…10
Compacting texture/material tables…
Reduced 12 texinfos to 4
Reduced 4 texdatas to 4 (81 bytes to 81)
Writing C:\Program Files (x86)\Steam\SteamApps\compmemlab\sourcesdk_content\Garrysmod\mapsrc\Practice1.bsp
0 seconds elapsed

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\orangebox\bin\vvis.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\compmemlab\garrysmod\garrysmod” “C:\Program Files (x86)\Steam\SteamApps\compmemlab\sourcesdk_content\Garrysmod\mapsrc\Practice1”

Valve Software - vvis.exe (May 19 2009)
2 threads
reading c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk_content\garrysmod\mapsrc\Practice1.bsp
reading c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk_content\garrysmod\mapsrc\Practice1.prt
LoadPortals: couldn’t read c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk_content\garrysmod\mapsrc\Practice1.prt

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\orangebox\bin\vrad.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\compmemlab\garrysmod\garrysmod” “C:\Program Files (x86)\Steam\SteamApps\compmemlab\sourcesdk_content\Garrysmod\mapsrc\Practice1”

Valve Software - vrad.exe SSE (May 19 2009)

Valve Radiosity Simulator
2 threads
Could not find lights.rad in lights.rad.
Trying VRAD BIN directory instead…
[Reading texlights from ‘c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\orangebox\bin\lights.rad’]
[48 texlights parsed from ‘c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\orangebox\bin\lights.rad’]

Loading c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk_content\garrysmod\mapsrc\Practice1.bsp
No vis information, direct lighting only.
Setting up ray-trace acceleration structure… Done (0.01 seconds)
96 faces
618951 square feet [89128960.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
sun extent from map=0.000000
2 direct lights
BuildFacelights: 0…1…2…3…4…5…6…7…8…9…10 (0)
Build Patch/Sample Hash Table(s)…Done<0.0000 sec>
FinalLightFace: 0…1…2…3…4…5…6…7…8…9…10 (0)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0…1…2…3…4…5…6…7…8…9…10 (2)
Writing leaf ambient…done
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness


models 1/1024 48/49152 ( 0.1%)
brushes 7/8192 84/98304 ( 0.1%)
brushsides 42/65536 336/524288 ( 0.1%)
planes 62/65536 1240/1310720 ( 0.1%)
vertexes 99/65536 1188/786432 ( 0.2%)
nodes 159/65536 5088/2097152 ( 0.2%)
texinfos 4/12288 288/884736 ( 0.0%)
texdata 4/2048 128/65536 ( 0.2%)
dispinfos 0/0 0/0 ( 0.0%)
disp_verts 0/0 0/0 ( 0.0%)
disp_tris 0/0 0/0 ( 0.0%)
disp_lmsamples 0/0 0/0 ( 0.0%)
faces 96/65536 5376/3670016 ( 0.1%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 6/65536 336/3670016 ( 0.0%)
leaves 161/65536 5152/2097152 ( 0.2%)
leaffaces 96/65536 192/131072 ( 0.1%)
leafbrushes 36/65536 72/131072 ( 0.1%)
areas 1/256 8/2048 ( 0.4%)
surfedges 408/512000 1632/2048000 ( 0.1%)
edges 205/256000 820/1024000 ( 0.1%)
LDR worldlights 2/8192 176/720896 ( 0.0%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 0/32768 0/393216 ( 0.0%)
waterstrips 0/32768 0/327680 ( 0.0%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 0/65536 0/131072 ( 0.0%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 0/512 0/180224 ( 0.0%)
LDR lightdata [variable] 0/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 0/16777216 ( 0.0%)
entdata [variable] 776/393216 ( 0.2%)
LDR ambient table 161/65536 644/262144 ( 0.2%)
HDR ambient table 161/65536 644/262144 ( 0.2%)
LDR leaf ambient 918/65536 25704/1835008 ( 1.4%)
HDR leaf ambient 161/65536 4508/1835008 ( 0.2%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/12 ( 8.3%)
pakfile [variable] 105667/0 ( 0.0%)
physics [variable] 584/4194304 ( 0.0%)
physics terrain [variable] 2/1048576 ( 0.0%)

Level flags = 0

Total triangle count: 192
Writing c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk_content\garrysmod\mapsrc\Practice1.bsp
2 seconds elapsed

** Executing…
** Command: Copy File
** Parameters: “C:\Program Files (x86)\Steam\SteamApps\compmemlab\sourcesdk_content\Garrysmod\mapsrc\Practice1.bsp” “c:\program files (x86)\steam\steamapps\compmemlab\garrysmod\garrysmod\maps\Practice1.bsp”

Things I noticed are that it says there is a leak despite me placing a box with the skybox texture over the entire map and this:

Loading c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk_content\garrysmod\mapsrc\Practice1.bsp
No vis information, direct lighting only.

There may be more but I haven’t seen them yet. Any help would be greatly appreciated.

Thank you very much, if this doesn’t belong here, please let me know and I’ll ask else where.

Oh, thank you. This confirms that there is a leak but I still do not know where it is or how to fix it.

I have the lights.rad file and I have downloaded but I guess I didn’t place it in the correct area. Where should it properly go?

I currently have it in:

c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\orangebox\bin\lights.rad

Do you have an info_player_start or any entity in your map for that matter? VBSP requires at least one entity to distinguish between your map’s interior and the void. Lacking the requirement, VBSP will return a generic leaked error, and since there’s no entity to leak, it won’t point to a specific entity.

Yep, I have one of those and I just double checked to see that was indeed an info_player_start one.

There is only one entity and it stands roughly in the middle of my map.

Should I take a screenshot of anything? Would that help?

Dont use gmod config.

Map> Load PointFile to find leaks

It be preferable that I use Garry’s mod when running around in my map because it will be much easier for me to arrange and place objects. That is the main reason why I’m trying to do this with Garry’s Mod.

[editline]09:56PM[/editline]

Sorry, I’m somewhat new at this still. If you could elaborate on that a bit more that would be perfect, thank you.

Compile the map

Click the Map button at the top of the screen

Then press Load Pointfiles

Alright, thank you guys for putting up with me so far. I just tried the method described by Seraph and there was nothing to load. I don’t have any files saved with the .pts or .lin name. I’m not sure if I was supposed to or if something’s wrong. Sorry.

.bsp

I beg your pardon? .bsp files aren’t an option either with the load pointfile thing either. I can’t select anything besides .pts or .lin type files.

Or did you mean something else? If I misinterpreted you I do apologize.

A pointfile will only be created if an entity is leaking.

.rad files are radiosity files used by VRAD to compute texture lighting. GMod doesn’t have any by default. Copy one from another game if needed.

So if there isn’t a pointfile that means that the entity isn’t leaking. But the compile log says there is a leak. Someone else suggested that it was a lack of an entity but this wasn’t the case. Do you have any other suggestions?

Also, I did managed to get a light.rad file and it’s in:

c:\program files (x86)\steam\steamapps\compmemlab\sourcesdk\bin\ora ngebox\bin\lights.rad

Would that be the correct place to put it?

If an entity was leaking, it would be logged. Is there a seperate section of the map without entities?

They’re usually found in the game’s root folder, but if it works there, problem solved.

There was a seperate section of the map (The area inbetween the skybox and the boxed in map) and I placed a random entity there but it still didn’t work I’m afraid.

What’s the root folder? Is it still important even though the extra entity didn’t work? And if so, where can I find it and what should I do?

Thank you again for your time.

[editline]11:15PM[/editline]

The main problem that I’m having at the moment is that I’m not sure where this leak is coming from. Any suggestions or ideas would be greatly appreciated.

Three examples of root folders:

“…\Steam\steamapps&lt;username>\half-life 2\hl2”

“…\Steam\steamapps&lt;username>\half-life 2 episode two\ep2”

“…\Steam\steamapps&lt;username>\garrysmod\garrysmod”

Oh, ok. I know what you’re referring to now. What exactly should I be searching for in these folders? Or what would be lacking in these folders that I should be noticing?