Garry's Mod Won't boot, process is running though

Hello,

Today I buyed a new laptop.
Asus X53S, Intel i7 Quad Core
4GB ram
OS: Win7 Home Premium 64-bit.

But, GMod and other steam games (CSS) won’t run…

If I click launch on any way (via steam, via steam > rightclick or via the desktop) it says “Launching GarrysMod…”.
When that dialogue is gone, the process (hl2.exe) is running, but the game isn’t.

SOMETIMES: The game does run, but then it just freezes at the startup screen… And in the corner it keeps saying “LOADING…”

I also tried to reinstall Steam and Gmod. No result.

I hope someone will help me out :slight_smile:

Add me on steam; blackshadowofgod

Greets,
TheBlackShadowOfGod

I have the same problem with CSS, GMOD, TF2 but not with HL2 or its episodes, i think it is a big problem with the recent source engine update. Hope someone will find a solution soon or rahter garry or valve sort the issue out.

I have the same problem’s, i have had the hl2.exe problem for quite a long time now, but the GMod freezing on startup only for 2ish week’s. I have tried reinstalling steam, deleting clientblob thingy, deleting registry values, trying to start the game with -window or -fullscreen and with -autoconfig, -dxlevel 81, it was also like this on my old windows 7 64Bit ( the hl2.exe running but no game, not the GMod freezing at startup that has only been happening for less than a month).

Problem fixed: It was my antivirus.

Make sure your antivirus isn’t blocking (parts) of GMod/CSS/… .
Also try to uninstall your antivirus, and see or the game boots then.

Also; make sure you got the latest updates regarding .NET Framework.

I hope this helps.

Greets,
TheBlackShadowOfGod

What AntiVirus did you have ?

Bitdefender 2011 Internet Security.

I now installed Microsoft Security Essentials.

damn i have bitdefender, i dont want to get rid of it though?

Great, i think i know now what the problem is, i have Bitdefender 2011 Total Security too :frowning:

Try disabling it. I don’t have bitdefender so I don’t know how to do it, but it should be possible.

Interesting.

Ive got the same problem on my new rig, as I posted in more detail here: http://www.facepunch.com/threads/1094852-GMod-won-t-launch-on-new-rig

I, too, have BD2011 and considered it to be the reason before, but disabling Firewall/AV/Antispam and Identity Protection does nothing to help the problem.

Besides, I had it on the old rig too, where GMod worked without any issues.

edit: Uninstalling BD did the trick. Now for a way to keep both…

[editline]6th June 2011[/editline]

Update: Fixed.

In Expert View, go to the Antivirus section > Shield tab > Advanced Settings > Exclusions Tab > click “+” and add the hl2.exe

Ye uninstalling bitdefender works i now have eset smart security and it works fine