Garry's mod Wont head over the Loading page

Hey guys.
I have really annoying problem.
I have just installed Gmod , Clicked on it then the loading screen came up
I have been waited for one hour for nothing , there is no blue line that shows up the loading stats only a guy holding the psy & tool guns and black square that says “loading” i never had that problem before…
I updated my Nvidia G-card.
I tried to turn off my Anti-virus
Checked the fire wall and allowed gmod.
Veferied the files redownload and reinstalled
tried that thing with “dxsetup 80” or whatever
or rename the gmod folder to “garrysmod old” so it could make new copy.
NOTHING!.
Help me guys i have no idea what to do next , any suggestions?
Thanks For Helping.

Is it a legit, non pirated copy?

I doubt it.

post your steam, make it public, so everyone can see it, if it’s not there, you pirated it

This, prove you have Garry’s Mod

Yes I have A legal Copy Here is my Community Page. : http://steamcommunity.com/id/76561197998108531
Hehe Now That i prooved i have Gmod , Any help please :)?

That profile is private. We can’t see it.

Specs help a lot.

Not private anymore
Now u can see.

My Specs:
Windows Ultimate 64x
4 GB Ram.
Intel. Quad 2.5
Nvidia 9600 1GB