Garry's mod won't launch for me now..

Whenever I try to load the game, it instantly crashes, and this message pops up. “Couldn’t Loadmodule Menusystem”.
So, anyone know anyway to fix this?

Tried resetting to vanilla GMod?

  1. Rename Steam/SteamApps/username/garrysmod to garrysmod_old
  2. Run GMod
  3. If it works, copy all addons and downloaded content from the old directory into the new directory which was automatically created.
  4. Delete the old folder
  5. If it doesn’t, you’re screwed.
  6. You didn’t realize there isn’t a number 5.
  7. You are now looking for number 5.
  8. You are now smiling.

That didnt work. Still saying Module menusystm isnt found.

Mine won’t go either… But mine says “hl2.exe stopped working” everytime I try to launch the game…

Ahh I see. Any source engine game I run returns this error: “Platform Error: bad module serverbrowser.dll not loading”
And that might explain why Gmod wont work. It’s complete bullshit.

I get this:
The instruction at “0x13b4632d” referenced memory at “0x110fb018”. The memory could not be “read”.
How do I fix that? I have the most up to date everything. Drivers, GMOD, and operating system.

^
That’s a memory error.
Sorry that’s the only help I could give. Is that a persistent error? To me, the first thing after an error is just to try again. If that doesn’t work restart the system. If that doesn’t work, post on here:
:siren: AND THEN PANIC!!11ONE :siren:

Could someone find their Menusystem module, and upload it? That might work.

I’m not panicing… I am getting pissed off. I have all the minimal requirements (except the processer, mines a bit better) and still won’t run, so yeah…

Actually, it is a persistent error and holy f*** is it annoying. I recently learned how to model and skin and I really wanted to test my model.

It was a joke, the panicking part. You could do a reinstall…and it didn’t work. Menusystem module, is that a dll? Does search Yes it is. Found under bin in gmod/gmod (as I call it). I could put its contents on here (with code tags, of course).

[editline]05:37PM[/editline]

I’ve only gotten a memory error like once, and it seemed to fix itself (or I deleted the problem :v:). I don’t know how to fix those, I’m not much of a hardware person. Did you recently install anything, GMod related or otherwise?

I have the .dll, and it still doesnt work.
Garry needs to get his shit together, and fix all these crashes, and once he does, stop fucking updating, it breaks everything.

Have you tried verifying “the integrity of the game cache”. I don’t know what exactly what it does, but it might help if something’s corrupted.

[editline]05:43PM[/editline]

But do I need to put the contents of mine on here?
I don’t even know if that will work, it’s assembly language, the browser might interpret it wrong, unless that’s what code tags are for.

You would have to upload the .dll on Rapidshare or something to ensure it works fully.

Ugh, more registration.

Actually visits site
Okay I guess not.

[editline]05:54PM[/editline]

Link:
http://rapidshare.com/files/404585465/MenuSystem.dll.html

Hurry, only 10 downloads!

I downloaded it,put it in the bin folder, still not working, thanks for trying though.
It’s garry’s fault, so now we wait and maybe he will fix it.

Ever since this has happened, all my source games died, mostly GMod

Mine only does that when I go in TF2.