Garry's Mod won't start, at all.

Hello everyone. I have a rather irritating problem. I’ve purchased this great game a long time ago, yet to my dismay, I have been unable to play it.

When I try to start Garry’s Mod, I’m greeted with the same message each and every time. “This game is currently unavailable. Please try again at another time.”

I think I have tried everything I can possibly attempt to play. I’ve attempted to re-download, I’ve removed any modifications, I’ve downloaded the SDK files… I simply can’t figure out what I’m doing wrong.

I’m running Vista, I have Half-Life Two and Team Fortress Two alongside Garry’s Mod. The SDK files I have downloaded are:

Source SDK
Source SDK Base
Source SDK Base - Orange Box

If you have any suggestions on what I should attempt to do, I would greatly appreciate them. I look forward to playing with the community, if ever possible.

Computer specs?
Tried defragmenting?
Tried verifying integrity of game files?
Tried reinstalling Gmod?
Tried reinstalling and deleting the garrysmod content gcf file?

Tried de-fragmenting - Yes
Tried verifying game integrity - Yes
Tried re-installing Garry’s Mod - Four times.
Tried re-installing and deleting GCF Content files - No. I’ll try that now.

Computer Specs-

System Model - Dell Inspiron 1420
Processor - Intel Pentium Dual CPU T2390 @ 1.86 GHz (Two CPUs), ~1.9GHz
Memory - 2038 MB of RAM
Page File - 2775 MB
Direct X 10

[editline]11:16PM[/editline]

I tried to re-install, and delete the G-Mod Content GCF File… I’m afraid it didn’t work.

As much as I hate to double post… Bump.

Have you launched any other source game at least once? (CSS / TF2 etc)

I’ve launched Team-Fortress Two, and Half-Life Two.

How long ago did you buy it?

I’d say three months. That is how long I’ve been trying to fix it.

Deleted your clientregistry.blob file with steam completely exited?

I haven’t tried that. Are you sure its safe to do?

Yup, completely safe, it’s also a method Steam give in their troubleshooter.

[editline]04:32PM[/editline]

Steam recreates it.

Alright, I’ll check it out.

[editline]03:57PM[/editline]

Didn’t work. Guess I’m screwed… I really wanted to play this game.

i bump this i kinda have the same problem

I don’t think it has anything to do with it but if it’s asking you to try at a different time it might be your drivers?

I have had this sometimes, all I ever have to do is restart steam.

Alternatively, you can also remove steam and then download + install it again (for a super-fresh start).
But you’ll have to download everything again and that might take a while.

Turn off firewall?

Nope, didn’t work.

Shame I can’t get a refund, eh? Oh well, ten dollars isn’t much. I’ll just wait for the next Garry’s Mod to come out.

Try http://support.steampowered.com
There might be a fix for unavailable games there.

How much HD space do you have?

Steam might not have enough wiggle room in there to run stuff.

There won’t be a new Garry’s Mod though, only updates. I doubt he’d wanna keep making new engines.