Garry's Mod won't start up [WINDOWS]

I think this started happening after update 13.06.07.

Whenever I launch gmod I get past the progress bar on the loading screen with ease quickly. However after that it will either A.) Get stuck on the blue screen except the progress bar and the facepunch logo dissappearing, or B.) It will get to the background screen but the main menu won’t appear. Now I made sure all my mounted games were verified including gmod. I ran each game at least once and I am also already opted in to the steam beta on the half-life 2/portal 1 single player games. Everything is in the common folder as well. When gmod first converted to steampipe it didn’t rename to garrysmod_old or whatever i actually had to force it to convert by validating. I also uninstalled gmod while backing up my dupes, saves, custom spawnlists, maps, and addons folders. I did a virus scan which didn’t return any threats or issues. All my other source games work perfectly. The first couple days after steampipe it loaded up just fine. Now after update 13.06.07 it will freeze unless I wait a very long time like 3-5 minutes and then it will go to the main menu.

Now I notice one of the patch changes in this update said this:


NEW Map Icons should now load much faster 
NEW Addons should now load much faster (especially if you have lots installed)

It appears the exact opposite is happening. I have around 400 addons installed and gmod never froze like this before this update. It would start up within 5 seconds after the blue screen. I looked around on the fourms and on SPUF to see if anyone else has this problem but apparently it’s just me. Usually when I have an issue everyone else has it. I also notice this big freezeup when i disable all my addons from the menu and when I try to mount or un-mount a game. It will freeze up for a long time like 2-3 minutes. It shouldn’t take this long to start up gmod, and as a test diagnosis I got rid of all the .GMA files in my addon folder and it started up instantly no problem, then it went to procede and “redownload” all those addons. Now before you say: remove some addons and stuff I reiterate that this didn’t start happening till after this update and I always had lots of addons installed.

In case any of this info will be useful here are the specs:

Processor Information:
Vendor: AuthenticAMD
Speed: 2394 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Unsupported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Windows 7 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: AMD M880G with ATI Mobility Radeon HD 4250
ATI Mobility Radeon HD 5650

DirectX Driver Name:  atiu9pag
Driver Version:  8.770.2.1000
DirectX Driver Version:  8.14.1.6143
Driver Date: 19 Sept 2010
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: ATI Mobility Radeon HD 5650
VendorID:  0x1002
DeviceID:  0x68c1
Number of Monitors:  1
Number of Logical Video Cards:  1
No SLI or Crossfire Detected
Primary Display Resolution:  1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 18.98" x 10.67"  (21.73" diag)
                                        48.2cm x 27.1cm  (55.2cm diag)
Primary Bus Type Not Detected
Primary VRAM: 336 MB
Supported MSAA Modes:  2x 4x 8x 

Sound card:
Audio device: Speakers and Headphones (IDT High Definition Audio Codec)

Memory:
RAM: 5882 Mb

EDIT: Here is a video of the crash: http://www.youtube.com/watch?v=roHw9lzBmFM&feature=youtu.be

.mdmps would be nice.

It would also be great knowledge to know WHAT Garry did to make those addons load faster so we can isolate what’s changed. I’ll try to figure it out in a little while.

This is the only one I could find. https://dl-web.dropbox.com/get/hl2_130609_crash_2013_6_9T20_18_15C0.mdmp?w=AAA-GXUCOJAy4099O5K8K9NarBKcnnvBFo_cI3asy1cAsw

Also I forgot to mention that I have to task manager out of gmod to get back to the desktop since its frozen. I also already tried following the steps in the facepunch support wiki: http://support.facepunchstudios.com/kb/articles/6-i-get-crashes-on-start-or-the-screen-is-just-black
I’m gonna try and take a video soon just to help do what I can to provide as much information about the problem as possible. Let me know if there’s any other information I can give and I’ll do my best to provide it. I see you help alot of people on here code_gs and I really appreciate it.

EDIT: code_gs I don’t think I’m the only one with this problem I found this thread of people complaining about long load times when starting up gmod (although the people here are mostly ranting and shitposting) but still take a look at it because some people are complaining about the same thing I am: http://steamcommunity.com/app/4000/discussions/1/864969953363492088/

You’re dropbox is private.

Just put the dump file here and send the link: http://dumps.metastruct.uk.to/

My apologies, I seemed to have overlooked that. Ok here’s the link on that dump processor site: http://dumps.metastruct.uk.to/dumper.py?dump=hl2_130609_crash_2013_6_9T20_18_15C0.mdmp&key=iGLbNKr4_lqrFUtZwOBlR8F-ZRX-xI1ArGopRRMbauf3hi54jv1ibusoTFlIP2iQ2HQ9VzUI06vJpw9pExlRsv1HupZJqD0VdC4ODjXT3x3H-QnbEDyjZlhEJ1La_pOGtbptAR0Ef4p6DySOPYIk4CzSmm_XBHYcdGRmgSMMcSQ=

So this happens right when it’s loading addons. I’m stumped to why loading addons faster just makes it crash…

I don’t suppose garry or max will look at or even pay attention to this issue? That SPUF thread i posted earlier people complain about similar issues. Should I submit an issue on github? I mean I tried providing as much information as I can… I feel like I tried everything I could.

Yeah, try github

[editline]10th June 2013[/editline]

Or try posting on the Rolling Updates thread.

Posted on the rolling updates thread and github. Honestly if I don’t get a response then I’m just going to assume I’m on my own to figure this out.

code_gs what do you suggest I do next because I posted my problem EVERYWHERE and thoroughly explained my issue. I’m kinda running out of patience. I want to play gmod. This is ridiculous! Sorry for ranting/shitposting but it’s frustrating when I did everything right in converting to steampipe and it doesn’t work out.

You’ve given it less than a day? You have a really low patience then.