Garry's Mod Won't Start

Hey there guys, so I have an issue. Basically when I run Garry’s Mod, it will say preparing to launch Garry’s Mod, then the little Garry’s Mod window will pop up on my task bar, but immediately close. Not sure what the issue is, I’m having trouble solving it though. Please help! Computer specs are fine, I have ran Garry’s Mod on this computer before. I recently reset the computer though.

Go to your Games folder in Steam, Right Click on Garry’s Mod and select “Properties”.
Go to the “Local Files” tab.
Press “Verify Integrity of Game Cache”.
Wait for it to do it’s thing.

If that doesn’t work, you should check if you installed any addons from the Workshop or manually from another site recently, that could somehow do it.

That was the first thing I tried. I’m doing it again right now for you though. I haven’t gotten any addons or anything, just downloaded the game on a wiped computer.

Still having the issue.

Did you update all your drivers and such?
Also try installing & reinstalling.
Otherwise, I got nothing for ya, mate.

They should all be updated. But I don’t get any errors or anything, I feel like I should if it was a driver issue. I did try re-installing and nothing. Thanks for trying though.

Still looking for help!