garrysmod fullscreen button-pressing doesnt work properly

[video]https://youtu.be/p23co_7tRtw[/video]
i tok my time to record the issue with my phone
it only happens in fullscreen, but i need to use fullscreen for shadowplay
the problem is that in fullscreen copy/paste is fucked up, so is whenever i click F1 i have to click f1 multiple times in a row before it responds to my buttonpress, same with escape menu it doesnt pop up again the menu it just refuses to close for a little bit

Try playing it in windowed borderless, shadowplay should still work.

-windowed -noborder

in launch options

ive been using -windowed -noborder for ages but shadowplay only works on fullscreen games. thats why i made this thread.

Use OBS?

no id rather use shadowplay

If you want to record using borderless fullscreen, you need to enable Shadowplay’s desktop recording functionality in the Geforce Experience settings. This should do what you want it to do.

its greyed out, using w10 gtx 950m, i5 core