garrysmod\garrysmod\lua _temp\entities - Can't see any entities

For some reason I suddenly wasn’t able to see any entities while playing Garry’s Mod. For example in Dark RP I can’t see any drugs, money printers, or in servers I can’t see custom banners or vmt/vtf files. And they aren’t errors, they just don’t appear. I’ve tried reinstalling Garry’s Mod a couple times now, and it never fixes it. For some reason I can’t delete the garrysmod\garrysmod\lua_temp\entities folder, and I believe that’s why I can’t see anything. I’ve tried changing permissions, and it won’t let me. Any ideas?

I have Windows 7 if that may be related to the problem.

Console errors that pretty much prove it:



Error creating blank file lua_temp\entities\info_spray\cl_init.lua
Error creating blank file lua_temp\entities\info_spray\shared.lua
Error creating blank file lua_temp\entities\st_hat\cl_init.lua
Error creating blank file lua_temp\entities\st_hat\shared.lua
Error creating blank file lua_temp\entities\st_trailpoint\shared.lua
Error creating blank file lua_temp\entities\weapon_spawn\cl_init.lua
Error creating blank file lua_temp\entities\weapon_spawn\shared.lua


Restart your computer.

facepalm Thanks.